• Hallo liebe Userinnen und User,

    nach bereits längeren Planungen und Vorbereitungen sind wir nun von vBulletin auf Xenforo umgestiegen. Die Umstellung musste leider aufgrund der Serverprobleme der letzten Tage notgedrungen vorverlegt werden. Das neue Forum ist soweit voll funktionsfähig, allerdings sind noch nicht alle der gewohnten Funktionen vorhanden. Nach Möglichkeit werden wir sie in den nächsten Wochen nachrüsten. Dafür sollte es nun einige der Probleme lösen, die wir in den letzten Tagen, Wochen und Monaten hatten. Auch der Server ist nun potenter als bei unserem alten Hoster, wodurch wir nun langfristig den Tank mit Bytes vollgetankt haben.

    Anfangs mag die neue Boardsoftware etwas ungewohnt sein, aber man findet sich recht schnell ein. Wir wissen, dass ihr alle Gewohnheitstiere seid, aber gebt dem neuen Board eine Chance.
    Sollte etwas der neuen oder auch gewohnten Funktionen unklar sein, könnt ihr den "Wo issn da der Button zu"-Thread im Feedback nutzen. Bugs meldet ihr bitte im Bugtracker, es wird sicher welche geben die uns noch nicht aufgefallen sind. Ich werde das dann versuchen, halbwegs im Startbeitrag übersichtlich zu halten, was an Arbeit noch aussteht.

    Neu ist, dass die Boardsoftware deutlich besser für Mobiltelefone und diverse Endgeräte geeignet ist und nun auch im mobilen Style alle Funktionen verfügbar sind. Am Desktop findet ihr oben rechts sowohl den Umschalter zwischen hellem und dunklem Style. Am Handy ist der Hell-/Dunkelschalter am Ende der Seite. Damit sollte zukünftig jeder sein Board so konfigurieren können, wie es ihm am liebsten ist.


    Die restlichen Funktionen sollten eigentlich soweit wie gewohnt funktionieren. Einfach mal ein wenig damit spielen oder bei Unklarheiten im Thread nachfragen. Viel Spaß im ngb 2.0.

Jupyter Notebook lässt sich nach spontanem Bluescreen nicht mehr korrekt bearbeiten und speichern

HoneyBadger

Aktiver NGBler

Registriert
7 Sep. 2015
Beiträge
1.956
Heute Morgen ist mein Computer ohne Grund abgestürzt. Seit diesem Moment kann ich meine Jupyter Notebooks in Visual Studio Code nicht mehr verwenden.

Ich habe keine hilfreiche Fehlermeldung erhalten. Mir ist nur aufgefallen, dass VSC Änderungen nicht mehr richtig erkennt, weil die Meldung, dass es ungespeicherte Änderungen gibt, in der Leiste der geöffneten Editoren nicht erscheint. Wenn ich aber die Datei schließe, werde ich gefragt, ob ich speichern möchte.

Wenn ich die Datei speichere, kann ich sie nicht mehr öffnen, weil VSC zwar versucht, sie zu öffnen, aber sie verschwindet direkt wieder.

Ich habe bereits versucht, eine ältere Arbeitsversion aus meinem Git-Repo neu zu laden. Ebenso mit einer frischen Kopie in einem neuen Verzeichnis. Aber da habe ich die gleichen Probleme. Dann habe ich versucht, einige der eingebauten Aufräumfunktionen von VSC zu nutzen, ich habe alle VSC-Cache-Ordner unter %appdata% gelöscht und auch eine Neuinstallation über die Reparaturfunktion durchgeführt.

Mir gehen langsam die Ideen aus, wie ich das Problem lösen kann.

Vielen Dank für jede Hilfestellung im Voraus!
 

Dr. M.

Weltmaschinenfahrer

Registriert
30 Juli 2018
Beiträge
189
Um das Problem mal etwas einzugrenzen: kannst du die betroffenen Notebooks im Browser öffnen, also per "jupyter notebook" (bzw. veraltet "ipython notebook") einen Server starten, dann per Browser auf http://localhost:8888/ gehen und dort das Notebook öffnen, benutzen und wieder speichern?

Wenn das funktioniert, ist das Problem sehr wahrscheinlich bei VSC bzw. deiner Konfiguration von VSC zu suchen.

Wenn es auch im Browser nicht funktioniert, sind vermutlich entweder deine Notebooks zerschossen, oder deine Jupyter-/Python-Installation.

In dem Fall könntest du das Ganze mal mit einem neu angelegten Notebook versuchen. Funktioniert auch ein neues Notebook nicht, ist wohl die Jupyter-Installation defekt. Andernfalls sind deine Notebooks das Problem.
 

HoneyBadger

Aktiver NGBler

Registriert
7 Sep. 2015
Beiträge
1.956
  • Thread Starter Thread Starter
  • #3
Ich kann die JN im Insider Built von VSC benutzen. Das habe ich mir gestern noch testweise installiert.

Es liegt ziemlich sicher an VSC. Ich habe bereits mehrfach vergeblich versucht, VSC samt Python etc. sauber zu deinstallieren. Keine Chance. Irgendwo übersehe ich scheinbar einen verstecken Ordner.

%LocalAppData%
%UserProfile%
%AppData%

Habe ich komplett manuel nach entsprechenden Spuren von VSC durchsuch.
Gleiches gilt für .vscode
Die Registry habe ich auch bereinigt. Alle caches und temp Ordner habe ich gelöscht. Die Umgebungsvariablen habe ich entfernt. Und bin analog mit Python vorgegangen. Half nicht.

Ich hatte zwischendurch auch mal Anaconda benutzt. Also vor ein paar Wochen. Da hatte der Kernel allerdings ein Problem. Daher habe ich hiervon auch alles entfernt, was ich finden konnte. VSC hat sich dort eine Zeit lang recht zwanghaft auf den Kernel gestürzt, statt den von mir zugewiesenen.
 

Dr. M.

Weltmaschinenfahrer

Registriert
30 Juli 2018
Beiträge
189
Wie gesagt, es waere hilfreich zu wissen, ob die Notebooks mit derselben Python-Umgebung im Browser funktionnieren. Wenn ja, dann koenntest du dir auch die Neuinstallationen von Python sparen :D

Um das Verhalten in VSC zu debuggen, lass mal die Developer Tools (Help -> Developer Tools) geoeffnet waehrend du das Notebook laedst/speicherst. Siehst du da irgendwelche "verdaechtigen" Exceptions oder Fehlermeldungen?
 

HoneyBadger

Aktiver NGBler

Registriert
7 Sep. 2015
Beiträge
1.956
  • Thread Starter Thread Starter
  • #5
Ich sagte ja bereits, dass sich das Jupyter Notebook im Insider Built von VSC ganz reuglär benutzen lässt. Die Dateien sind also in Ordnung. Dafür brauche ich ja keine dritte Software. Nachfolgend die DevTools.

 

Dr. M.

Weltmaschinenfahrer

Registriert
30 Juli 2018
Beiträge
189
Danke fuer das Log, aber ich sehe da nichts wirklich verdaechtiges. Was mir etwas seltsam erscheint ist dass die Extension offensichtlich 2 Kernel gleichzeitig startet. Hattest du da 2 Notebooks gleichzeitig geoeffnet, etwa in einem Workspace?

Zum Vergleich, so sieht's bei mir mit VSCode 1.52.1 und Python 3.7.3 (Anaconda) aus:


Uebrigens, Jupyer im Browser ist keine "dritte Software", sondern das eingebaute Standardinterface von Jupyer Notebook/Lab. Die IDEs (VSCode, PyCharm, ...) bauen da etwas darum rum. Kann praktisch sein, kann funktionieren, hat aber in der Vergangenheit gerade bei komplexeren Notebooks mit vielen Plots und ggf. eigenem html/js-Output, auch immer mal wieder Probleme gemacht, oft in Verbindung mit Jupyer-Upgrades. Deshalb meine Empfehlung, es im Zweifel immer erst mal im Browser zu probieren ...

Ich sehe z.B. dass du eine recht neue Python-Version (3.9 gemaess den Pfaden) hast. Hattest du schon vor dem Problem diese Version genutzt? Die Unterstuetzung von 3.9 in VSCode ist noch ganz frisch und mich wuerden "Kinderkrankheiten" nicht wundern. Wenn du 3.8 hast, eventuell mal damit probieren. Oder halt temporaer das Insiders Build verwenden und darauf hoffen, dass sich das Problem mit dem naechsten Release erledigt hat.

Falls du weiter debuggen moechtest, waere der naechste Schritt, in den Python-Einstellungen das Log-Level aufzudrehen (von Error auf Info oder Trace).
 

HoneyBadger

Aktiver NGBler

Registriert
7 Sep. 2015
Beiträge
1.956
  • Thread Starter Thread Starter
  • #7
Hi und sorry erstmal,

dass ich erst so spät antworte. Hatte vergessen, die Benachrichtigungen einzustellen und habe es daher schlicht übersehen.

Eine tiefere Analyse können wir uns nun glücklicherweise sparen. Bin mangels Zeit eine Weile nicht dazu gekommen. Das letzte VS Code Update hat das Problem "von Zauberhand" gelöst. Passt wieder alles.

VG
 
Oben