• Hallo liebe Userinnen und User,

    nach bereits längeren Planungen und Vorbereitungen sind wir nun von vBulletin auf Xenforo umgestiegen. Die Umstellung musste leider aufgrund der Serverprobleme der letzten Tage notgedrungen vorverlegt werden. Das neue Forum ist soweit voll funktionsfähig, allerdings sind noch nicht alle der gewohnten Funktionen vorhanden. Nach Möglichkeit werden wir sie in den nächsten Wochen nachrüsten. Dafür sollte es nun einige der Probleme lösen, die wir in den letzten Tagen, Wochen und Monaten hatten. Auch der Server ist nun potenter als bei unserem alten Hoster, wodurch wir nun langfristig den Tank mit Bytes vollgetankt haben.

    Anfangs mag die neue Boardsoftware etwas ungewohnt sein, aber man findet sich recht schnell ein. Wir wissen, dass ihr alle Gewohnheitstiere seid, aber gebt dem neuen Board eine Chance.
    Sollte etwas der neuen oder auch gewohnten Funktionen unklar sein, könnt ihr den "Wo issn da der Button zu"-Thread im Feedback nutzen. Bugs meldet ihr bitte im Bugtracker, es wird sicher welche geben die uns noch nicht aufgefallen sind. Ich werde das dann versuchen, halbwegs im Startbeitrag übersichtlich zu halten, was an Arbeit noch aussteht.

    Neu ist, dass die Boardsoftware deutlich besser für Mobiltelefone und diverse Endgeräte geeignet ist und nun auch im mobilen Style alle Funktionen verfügbar sind. Am Desktop findet ihr oben rechts sowohl den Umschalter zwischen hellem und dunklem Style. Am Handy ist der Hell-/Dunkelschalter am Ende der Seite. Damit sollte zukünftig jeder sein Board so konfigurieren können, wie es ihm am liebsten ist.


    Die restlichen Funktionen sollten eigentlich soweit wie gewohnt funktionieren. Einfach mal ein wenig damit spielen oder bei Unklarheiten im Thread nachfragen. Viel Spaß im ngb 2.0.

VLC spielt 5k Video nicht ab

Roin

Freier Denker

Registriert
22 Juli 2013
Beiträge
579
Hallo zusammen,

ich habe von einem Kollegen mehrere 5K Video Dateien erhalten, die er ohne jegliche Konvertierung auf seinem Computer mit dem VLC Player abspielen kann. Diese wurden mit einer Drone aufgenommen und sind mit HEVC codiert.
Genauer Codec: MPEG-H Part2/HEVC (H.265) (hvc1)
Videoauflösung: 5472x3078
Pufferabmessung: 5472x3104
Bildwiederholrate 29.970029
Decodiertes Format: Planar 4:2:0 YUV

Wenn ich versuche die Videos auf meinem Computer abzuspielen habe ich entweder ein schwarzes Video (Zeit läuft ab) oder ein Standbild von einem der ersten Frames.

Das ist mein Computer:
AMD Ryzen 9 5900x CPU
Gigabyte RTX 3070 TI Grafikkarte
NVME SSDs auf denen die Videos gespeichert sind
64 GB RAM
Windows 10 Pro installiert
Derzeit zwei 4k Monitore an der Grafikkarte angeschlossen


Der VLC meldet beim Starten der Videos folgendes:
direct3d11 error: SetThumbNailClip failed: 0x800706f4
d3d11va error: No decoder configuration possible for NV12 5472x3078
d3d11va error: No decoder configuration possible for NV12 5472x3078
d3d11va error: No decoder configuration possible for I420_OPAQUE 5472x3078
d3d11va error: No decoder configuration possible for P010 5472x3078
d3d11va error: No decoder configuration possible for I420_OPAQUE 5472x3078
d3d11va error: FindVideoServiceConversion failed
direct3d11 error: SetThumbNailClip failed: 0x800706f4
dxva2 error: IDirectXVideoDecoderService_GetDecoderConfigurations failed. (hr=0x80004005)
direct3d11 error: SetThumbNailClip failed: 0x800706f4
avcodec error: avcodec_send_packet critical error

Beim Versuch die Videos mit dem abzuspielen hat sich zwar etwas bewegt, allerdings war zwischen den sauberen Bildern sehr viel graue Matsche zu sehen.

Was ich schon versucht habe:
  • Videos auf einer anderen SSD abspeichern und von dort abspielen
  • Verschiedene 5k Videos ausprobiert
  • Full-HD Videos haben keine Probleme
  • 4k-MKV Videos (mit OBS aufgenommen) haben ebenfalls keine Probleme
  • Im VLC Player die Ausgabe auf Direct3D11 stellen
  • Hardwarebeschleunigung deaktivieren

Mein Kollege sagt, er hat den VLC Player installiert und nichts anderes angeklickt oder umgestellt.
Habt ihr noch Vorschläge, was ich ausprobieren kann?

Die ersten Google-Ergebnisse habe ich bereits durch und habe auch nach Umstellen der Einstellungen im VLC den VLC erst beendet bevor ich das Video erneut ausprobiert habe.
 

Steev

(ツ)

Registriert
15 Juli 2013
Beiträge
28.905
Ort
Hannover
Mit noch anderen Playern MPV oder ffplay aus dem FFmpeg?





Bei ffplay, Datei/Video in den bin Ordner legen und
Code:
ffplay DATEI
in der Konsole ausführen.
 
Zuletzt bearbeitet:

Roin

Freier Denker

Registriert
22 Juli 2013
Beiträge
579
  • Thread Starter Thread Starter
  • #3
Mit noch anderen Playern MPV oder ffplay aus dem FFmpeg?

Der mpv spielt die Videos ab, jedoch mit Stottern. Wenn ich im Taskmanager nach der Lesegeschwindigkeit der SSD gucke ist das weit weg von dem möglichen. Meine SSD kann ~ 7000 MB/s und ich bin in der Größenordnung von 20MB/s.
Auch meine Grafikkarte ist nicht ausgelastet, alle Diagramme weit weg von der oberen Grenze.
CPU ist ebenfalls nahezu idle, 6 von 24 Threads ~ 50%.

Direktes Abspielen mit ffplay funktioniert schlechter als mit mpv. Ich sehe vielleicht 5 Frames, dann erstmal wieder eine Sekunde Pause.

Noch weitere Ideen oder vielleicht sogar schon eine Erkenntnis?
 
Zuletzt bearbeitet:

Steev

(ツ)

Registriert
15 Juli 2013
Beiträge
28.905
Ort
Hannover
Könntest du mir ein Snippet zukommen lassen? Mit Avidemux kannst du ein paar Frames als mp4 o. mkv/HEVC/H.265 speichern und mir schicken. Würde ich gerne mal hier testen.
 

Roin

Freier Denker

Registriert
22 Juli 2013
Beiträge
579
  • Thread Starter Thread Starter
  • #5

Du hast bei dir ja auch festgestellt, dass es stottert im mpv.

Konntest du es denn im VLC abspielen?
Liegt das wirklich an den Videos oder sind da irgendwelche Einstellungen oder so einfach nicht gut?
 

Steev

(ツ)

Registriert
15 Juli 2013
Beiträge
28.905
Ort
Hannover
Ich habe die Snippets ja mal verkleinert im Seitenverhältnis und einen anderen HEVC Codec verwendet mit Avidemux.

Deine Snippets in bsw. Breite px 2048 x ... und das Video lässt sich problemlos abspielen.

Ich denke es liegt einfach an der Breiten px Größe von 5000+, die die Player überfordert.

Siehe dazu die PN ;)

Edit: Ich habe eben das Seitenverhältnis belassen und nur den HEVC Codec von Avidemux verwendet. Ich wollte testen, ob es am Codec liegt.

Nein, auch da stottert mpv, so dass man jetzt schlussendlich sagen kann, dass es an der pixel Größe liegt/Auflösung.

Die Frage bleibt, ab welcher Größe mpv und Co damit klar kommen?

Edit2:

Jap, 4K ist das Maximum des möglichen bei mpv & Co.. Dein Snippet verkleinert auf 4096px und es läuft. Das heißt die Player sind noch nicht 5K-fähig.
 
Zuletzt bearbeitet:

Brother John

(schein)heilig
Teammitglied

Registriert
1 Aug. 2013
Beiträge
235
Stoßt ihr evtl. ans Limit vom Hardware-Decoding? Da würde mich ein relativ hartes Auflösungslimit nicht besonders wundern. Rein in Software leuchtet’s mir nicht ein, wenn der Rechner dabei nicht an eine Leistungsgrenze kommt. Ein paar Pixel mehr oder weniger ändern ja nichts grundsätzliches am Video.
 

Roin

Freier Denker

Registriert
22 Juli 2013
Beiträge
579
  • Thread Starter Thread Starter
  • #8
Sollte aber bei deaktivierter Hardware-Beschleunigung nicht zumindest etwas im VLC angezeigt werden?
 

Brother John

(schein)heilig
Teammitglied

Registriert
1 Aug. 2013
Beiträge
235
Eigentlich schon. Ein kaputter Container wäre auch noch eine Möglichkeit, dann könnte neu muxen helfen.
 

drfuture

Zeitreisender
Teammitglied

Registriert
14 Juli 2013
Beiträge
7.766
Ort
in der Zukunft
Versuch einmal folgendes:

Starte den VLC Media Player

Klicke im erscheinenden Fenster in der oberen Navigationsleiste auf die Schaltfläche Werkzeuge
Dort sollte ein Punkt namens Einstellungen auftauchen, diesen anwählen
In nun sich öffnenden Fenster sollte oben der Reiter Interface ausgewählt sein
In den Interface-Einstellungen sollte man nun den Punkt Interface an Videogröße anpassen finden
Entferne dort den Haken
Bestätige die Einstellungsänderung abschließend mit einem schwungvollen Klick auf Speichern
Alles was jetzt noch fehlt ist ein Neustart des VLC Media Players
 

Roin

Freier Denker

Registriert
22 Juli 2013
Beiträge
579
  • Thread Starter Thread Starter
  • #11

Gerade frisch ausprobiert. Hat leider nicht geholfen. Und ja, ich habe den VLC Player danach geschlossen und das Video anschließend geöffnet. Entweder war nur der erste Frame zu sehen oder direkt ein schwarzes Bild.
 

drfuture

Zeitreisender
Teammitglied

Registriert
14 Juli 2013
Beiträge
7.766
Ort
in der Zukunft
Kannst du mal noch versuchen den 2. Monitor abzustecken?
Kommt immer noch die gleiche Meldung im log?
 

Roin

Freier Denker

Registriert
22 Juli 2013
Beiträge
579
  • Thread Starter Thread Starter
  • #13

Bildschirm dublizieren / Bildschirm ausschalten / Bildschirm-Displayportkabel abstecken. Alles das gleiche.
Ich habe auch das mit der Videogröße wieder deaktiviert und auch die Hardwarebeschleunigung.

Dublizieren:
main error: buffer deadlock prevented
direct3d11 error: SetThumbNailClip failed: 0x800706f4
direct3d11 error: SetThumbNailClip failed: 0x800706f4
direct3d11 error: SetThumbNailClip failed: 0x800706f4
avcodec error: avcodec_send_packet critical error
main error: buffer deadlock prevented

Ausschalten:
main error: buffer deadlock prevented
direct3d11 error: SetThumbNailClip failed: 0x800706f4
direct3d11 error: SetThumbNailClip failed: 0x800706f4
direct3d11 error: SetThumbNailClip failed: 0x800706f4
avcodec error: avcodec_send_packet critical error

Abgesteckt:
main error: buffer deadlock prevented
direct3d11 error: SetThumbNailClip failed: 0x800706f4
direct3d11 error: SetThumbNailClip failed: 0x800706f4
direct3d11 error: SetThumbNailClip failed: 0x800706f4
avcodec error: avcodec_send_packet critical error

Wenn ich den VLC Player beim Abspielen (Schwarzes Video) verschiebe, insbesondere an den Displayrand schiebe (und er damit angepinnt wird) schmiert der VLC einfach ab.
 

drfuture

Zeitreisender
Teammitglied

Registriert
14 Juli 2013
Beiträge
7.766
Ort
in der Zukunft
Also ich würde darauf schließen das er versucht auf Monitor 2 ( der der aus war ) 5k Pixel zu erstellen, was in keinem Fall funktionieren kann.
Die Frage ist ob der Tat warum bzw. Wie man das ändern kann.

Die Option dass Interface an die Videogröße anzupassen macht für mich immer Sinn, dann ist das Fenster nicht je nach Video beim Start unterschiedlich groß ;)

Hast du eine Software der Graka die das rein funkt?
 

Roin

Freier Denker

Registriert
22 Juli 2013
Beiträge
579
  • Thread Starter Thread Starter
  • #15
Hast du eine Software der Graka die das rein funkt?
Ich habe eine Gigabyte RTX 3070 TI. Entsprechend habe ich den aktuellen NVIDIA Treiber installiert und Geforce Experience installiert. Da scheint der VLC aber nicht von beeinflusst zu werden. Zumindest habe ich dort nirgendswo etwas dazu gefunden.
 

Steev

(ツ)

Registriert
15 Juli 2013
Beiträge
28.905
Ort
Hannover
also bei mir ist es definitiv die fehlende Hardware die 5k kann. Ich habe deine Snippets ja heruntergeschraubt auf 4K und es läuft, ich hörte 5k auch durch diesen Thread das erste mal. Es ist einfach auch ein Performance Wunsch, den trotz potenter HW noch nicht jeder PC erfüllt. Diese 5k wie ich jetzt festellte haben aber auch ein anderes Problem. Sie überschreiten die Bildschirmauflösung! Make it sense? Dieses stottern, ich kann des mir technisch erklären, behaupte aber mal, ja VLC und Co. sollen sowas auch gar nicht abspielen. ffplay macht es am deutlichsten, das ist das Video in Original Größe und sprengt deinen Bildschirm. Muss das sein? Deine Videos sind GB Groß, mehrere GB und ich verstehe, dass du das nicht konvertieren willst, aber sry, whatever, höher schneller weiter ist an dieser Stelle nicht mehr sinnig. Du zeigst den Dachgiebel mit einer Drohne, hm.
 
Oben