• Hallo liebe Userinnen und User,

    nach bereits längeren Planungen und Vorbereitungen sind wir nun von vBulletin auf Xenforo umgestiegen. Die Umstellung musste leider aufgrund der Serverprobleme der letzten Tage notgedrungen vorverlegt werden. Das neue Forum ist soweit voll funktionsfähig, allerdings sind noch nicht alle der gewohnten Funktionen vorhanden. Nach Möglichkeit werden wir sie in den nächsten Wochen nachrüsten. Dafür sollte es nun einige der Probleme lösen, die wir in den letzten Tagen, Wochen und Monaten hatten. Auch der Server ist nun potenter als bei unserem alten Hoster, wodurch wir nun langfristig den Tank mit Bytes vollgetankt haben.

    Anfangs mag die neue Boardsoftware etwas ungewohnt sein, aber man findet sich recht schnell ein. Wir wissen, dass ihr alle Gewohnheitstiere seid, aber gebt dem neuen Board eine Chance.
    Sollte etwas der neuen oder auch gewohnten Funktionen unklar sein, könnt ihr den "Wo issn da der Button zu"-Thread im Feedback nutzen. Bugs meldet ihr bitte im Bugtracker, es wird sicher welche geben die uns noch nicht aufgefallen sind. Ich werde das dann versuchen, halbwegs im Startbeitrag übersichtlich zu halten, was an Arbeit noch aussteht.

    Neu ist, dass die Boardsoftware deutlich besser für Mobiltelefone und diverse Endgeräte geeignet ist und nun auch im mobilen Style alle Funktionen verfügbar sind. Am Desktop findet ihr oben rechts sowohl den Umschalter zwischen hellem und dunklem Style. Am Handy ist der Hell-/Dunkelschalter am Ende der Seite. Damit sollte zukünftig jeder sein Board so konfigurieren können, wie es ihm am liebsten ist.


    Die restlichen Funktionen sollten eigentlich soweit wie gewohnt funktionieren. Einfach mal ein wenig damit spielen oder bei Unklarheiten im Thread nachfragen. Viel Spaß im ngb 2.0.

OpenWRT auf einen Linkysys 54g3g v.1.1 flashen via USB zu TTL serial adapter – geht das irgendwie noch?

goldsteal

Neu angemeldet

Registriert
29 Okt. 2013
Beiträge
10
Ort
Köln
Moin zusammen!
Kleine Frage an die Bastler, Jailbreaker und Lötfanatiker unter euch...

Ich hatte mir ein kleines Wochendprojekt aufgehalst und einen – also einen uralten Router mit sehr kleinem Flashspeicher, der logischerweise nur dementsprechend alte OpenWRT Versionen unterstützen kann – rausgekramt und es mir zur Aufgabe gemacht, den auf die aktuellste OpenWRT firmware, die ich für ihn finden kann, zu flashen. Im Endeffekt also so, wie man es vielleicht Anno 2008 getan hätte. ;)

Los ging die Reise: Router aufgeschraubt, angelötet, USB zu TTL Adapter rausgekramt – dann festgestellt, dass der nicht mit lsusb aufgelistet wird und einen anderen gekauft – und das Ding mit dem PC verbunden. So weit, so gut. Jetzt weiß ich nicht wirklich weiter. Was wären die nächsten Schritte bei so etwas?

Anleitungen für andere Router, bei denen ich mir vielleicht was ableiten könnte, sind meist auf ältere Windows Betriebsysteme (z.B. Windows XP) abgestimmt, während ich hingegen hierfür meine Linux-Kiste (Linux auf Debian-Basis bzw. Linux Mint 19.3 Cinnamon mit dem aktuellen Kernel 5.6.2) verwenden will. Rausfinden konnte ich, dass man statt PuTTY auf Windows für sowas unter Linux CuteCom verwenden kann – wie zum Beispiel beschrieben.

Wenn ich das installiere, den Adapter anschließe und starte, scheint der Adapter auch erkannt zu werden (auf /dev/ttyUSB0 ein SiliconLabs CP2102 USB to UART Controller).
Gemäß dem Fall, dass das so ordnungsgemäß ist, nun das erste Problem – CuteCom spuckt mir einen Fehler aus:
CuteCom - error_permission_denied.png

Mit root-Rechten via sudo – [src=bash]sudo cutecom[/src] – scheint es zu funktionieren:
CuteCom - Default_202.png
Vorausgesetzt, dass man wirklich CuteCom root-Rechte geben muss, wie gehe ich jetzt weiter vor?

Eine möglicherweise passende Firmware mit der unhandlichen Bezeichnung
openwrt-wrt54g3g-2.4-squashfs.bin
konnte ich bereits finden.
Aber nicht welche Befehle ich eingeben muss, um überhaupt erstmal herauszufinden, ob die Verbindung steht (somit die Kabel richtig angelötet sind) und schon garnicht, wie ich den eigentlichen Flash jetzt durchführen muss...

Falls irgendwer zufällig sowas noch weiß, wäre ich um jede Hilfe dankbar. Im OpenWRT Forum frage ich erstmal nur deshalb nicht nach, weil man den Router schon lange nicht mehr als kompatibel ansieht und ich nicht weiß, ob das jemandem auf die Füße treten würde, im ngb war das bisher immer weniger ein Problem.

Mit abenteuerlichen Grüßen

goldsteal

P.S.: Bitte in einen treffendenderen Bereich des ngb verschieben, falls vorhanden.
 

rexcolo

NGBler

Registriert
16 Sep. 2017
Beiträge
132
Vorausgesetzt, dass man wirklich CuteCom root-Rechte geben muss, wie gehe ich jetzt weiter vor?
Du könntest auch einfach die Rechte auf /dev/ttyUSB… ändern, bspw mit polkit.

Aber nicht welche Befehle ich eingeben muss, um überhaupt erstmal herauszufinden, ob die Verbindung steht
dat is ne serielle verbindung. da kommt entweder was rein oder raus. wenn nix rauskommt sendet der andere teilnehmer nix.

hier ist doch ne gute anleitung von openwrt:
 

goldsteal

Neu angemeldet

Registriert
29 Okt. 2013
Beiträge
10
Ort
Köln
  • Thread Starter Thread Starter
  • #3
Du könntest auch einfach die Rechte auf /dev/ttyUSB… ändern, bspw mit polkit.

dat is ne serielle verbindung. da kommt entweder was rein oder raus. wenn nix rauskommt sendet der andere teilnehmer nix.

hier ist doch ne gute anleitung von openwrt:

Ja, dat han ich so jetzt och verstanden... äääver...
Sollte der Router nicht beim Boot was senden? Irgendwie krieg ich nix und habe leicht das Gefühl, dass ich die Kontakte gegrillt hab' #loetenfueranfaenger :D

Das mit den Rechten hätte sich aber schonmal geklärt. Besten Dank! :)
 

rexcolo

NGBler

Registriert
16 Sep. 2017
Beiträge
132
na ja dann musst du wohl mit dem Oszilloskop dran und schauen ob sich da irgendwas tut
 
Oben