Seite 3 von 3 ErsteErste 123
Ergebnis 51 bis 57 von 57

Thema: [Xubuntu 18.04.4 LTS] Thinkpad x230 Built-in Kamera funktioniert nicht

  1. #51
    Vereinsheimer Avatar von Laui
    Registriert seit
    Jul 2013
    Beiträge
    19.329
    ngb:news Artikel
    2

    Re: [Xubuntu 18.04.4 LTS] Thinkpad x230 Built-in Kamera funktioniert nicht

    Ja ich emfehle aber trotzdem immer auf die aktuelle Ubuntu LTS aufzusteigen und zwar mit einem Clean-Install, allein und darüber sprechen wir ja hier auch in Bezug auf neueren Kernel und damit verbunden bessere Treiber etc..
    In 9 Tagen ist offzieller Release. Wäre ich du, würde ich jetzt mal ein Windows 10 Install dazwischen-schieben, einfach um zu sehen ob das mit deiner Cam nicht wirklich nur ein Linux "Problem" ist.

  2. #52
    Mitglied
    Registriert seit
    Jul 2013
    Ort
    /dev/null
    Beiträge
    2.749

    Re: [Xubuntu 18.04.4 LTS] Thinkpad x230 Built-in Kamera funktioniert nicht

    Zitat Zitat von Kenobi van Gin Beitrag anzeigen
    Code (Bash):
    1. dmesg | grep -i cam
    2. [    0.000000]   AMD AuthenticAMD
    3. [    3.095517] usb 1-1.6: Product: Integrated Camera
    4. [   16.175022] uvcvideo: Found UVC 1.00 device Integrated Camera (5986:02d2)
    5. [   16.204264] uvcvideo 1-1.6:1.0: Entity type for entity Camera 1 was not initialized!
    6. [   16.204354] input: Integrated Camera: Integrated C as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.6/1-1.6:1.0/input/input16
    7.  
    Na das ist doch schon mal was.

    Wir hätten jetzt mal als konkretes Ergebnis:



    Wenn man den Bugreport hier betrachtet, scheint der Treiber tatsächlich kaputt zu sein.
    camera worked pre kernel 4's and before going from Ubuntu 18 - 19
    Hier dazu noch der Bug auf kernel.org.

    Der Bugreport ist noch offen. Demnach wirst du wohl auch mit Ubuntu 20 keinen Erfolg haben.
    Für diesen Beitrag bedankt sich Kenobi van Gin

  3. #53
    Brillenschlange

    (Threadstarter)

    Avatar von Kenobi van Gin
    Registriert seit
    Jul 2013
    Ort
    .\
    Beiträge
    3.514
    ngb:news Artikel
    1

    Re: [Xubuntu 18.04.4 LTS] Thinkpad x230 Built-in Kamera funktioniert nicht

    Genau, diesen Bugreport hatte ich ja auch schon gefunden.
    Passiert sowas? Also dass ein Gerät unter Linux einwandfrei funktioniert und dann auf mal (bzw. offenbar ja mit einem Kernel-Update) nicht mehr? Heißt das denn nun immerhin schonmal, dass die Kamera an sich (wahrscheinlich) noch funktioniert?

    Mein Problem ist, dass ich den Laptop produktiv nutze und natürlich nicht mal eben ein neues OS installieren will, um was zu testen, wenn ich danach alles wieder so einrichten muss, wie ich es vorher hatte, bevor ich vernünftig weiterarbeiten kann. Unter Windows als VM bleibt das Problem bestehen. Macht aber ja auch Sinn, weil das OS in der VM ja meines Wissens die tatsächliche Hardware gar nicht zu sehen, sondern von der Emulationssoftware virtuelle Hardware zur Verfügung gestellt bekommt, richtig? Entsprechend würde das Problem vom Host ja durchgereicht.

  4. #54
    Mitglied
    Registriert seit
    Jul 2013
    Ort
    /dev/null
    Beiträge
    2.749

    Re: [Xubuntu 18.04.4 LTS] Thinkpad x230 Built-in Kamera funktioniert nicht

    Zitat Zitat von Kenobi van Gin Beitrag anzeigen
    Passiert sowas? Also dass ein Gerät unter Linux einwandfrei funktioniert und dann auf mal (bzw. offenbar ja mit einem Kernel-Update) nicht mehr?
    Das kann durchaus vorkommen, dass ein Treiber durch ein Kernelupdate nicht mehr funktioniert. Das kann auch mehrere Ursachen haben. Entweder wurde der Treiber selbst umgebaut, um z.B. neue Geräte zu unterstützen. Gerade uvcvideo unterstützt ja eigentlich so ziemlich alle neueren Webcams. Andererseits kann sich aber auch in anderen Komponenten was ändern. Beispiel wäre hier der v4l-Unterbau. Dann müssten halt die abhängigen Treiber angepasst werden.

    Ich hatte bei meiner NAS mal das Problem, dass nach einem Kernelupgrade der NFS-Server nach einer gewissen Zeit immer abstürzte. Das Log hat mir dann verraten, dass der Netzwerktreiber (mvneta) der Übeltäter war. Also hab ich die Firma angeschrieben, die den Treiber entwickelt hat. Und in der Tat hatten sie so einige Änderungen drin und in der neueren Version einen Schleifenüberlauf produziert. Es lief darauf hinaus, dass die mir die Diffs schickten und ich den Kerneltreiber für die getestet hatte. Als wir dann den Übeltäter identifiziert hatten, erstellten sie einen Patch. In der nächsten Kernelversion war dann der Treiber wieder einsatzfähig. Bis das gefixt war, vergingen schon so einige Wochen.

    Und vor 15 Jahren hatte ich mir mal in Korea eine Billig-Webcam gekauft. Die wurde zwar vom GSPCA-Treiber (ältere Generation) erkannt, brachte aber nur ein schwarzes Bild. Also schrieb ich den Treiberentwickler an (war ein Franzose). Und wie das halt so mit Billigcams ist, wich das Ding in irgendeiner Form vom Standard ab. Er brauchte von mir die INF-Datei aus dem Windowstreiber. Ein paar Wochen später funktionierte das Ding dann.


    Zitat Zitat von Kenobi van Gin Beitrag anzeigen
    Unter Windows als VM bleibt das Problem bestehen. Macht aber ja auch Sinn, weil das OS in der VM ja meines Wissens die tatsächliche Hardware gar nicht zu sehen, sondern von der Emulationssoftware virtuelle Hardware zur Verfügung gestellt bekommt, richtig?
    Nicht unbedingt. Für bestimmte Komponenten stellt Dir der Hypervisor virtuelle Devices zur Verfügung, z.B. Motherboard, Festplatte, Grafikkarte. Du kannst aber auch andere Devices einfach durchreichen (gerade bei USB). Dazu musst du den Treiber im Hostsystem entladen (modprobe -r uvcvideo, modprobe -r uvc) und kannst die Geräte-ID direkt an den Gast weiterleiten. Die Webcam sollte dann in der Windows-VM mit dem Windowstreiber problemlos funktionieren.

  5. #55
    Brillenschlange

    (Threadstarter)

    Avatar von Kenobi van Gin
    Registriert seit
    Jul 2013
    Ort
    .\
    Beiträge
    3.514
    ngb:news Artikel
    1

    Re: [Xubuntu 18.04.4 LTS] Thinkpad x230 Built-in Kamera funktioniert nicht

    Zitat Zitat von musv Beitrag anzeigen
    Nicht unbedingt. Für bestimmte Komponenten stellt Dir der Hypervisor virtuelle Devices zur Verfügung, z.B. Motherboard, Festplatte, Grafikkarte. Du kannst aber auch andere Devices einfach durchreichen (gerade bei USB). Dazu musst du den Treiber im Hostsystem entladen (modprobe -r uvcvideo, modprobe -r uvc) und kannst die Geräte-ID direkt an den Gast weiterleiten. Die Webcam sollte dann in der Windows-VM mit dem Windowstreiber problemlos funktionieren.
    Das könnte ich also auch nochmal testen. Muss ich für "die Geräte-ID an den Gast weiterleiten" irgendwas Bestimmtes machen? Oder passiert das automatisch, wenn ich den Treiber im Host kille?

  6. #56
    Mitglied
    Registriert seit
    Jul 2013
    Ort
    /dev/null
    Beiträge
    2.749

    Re: [Xubuntu 18.04.4 LTS] Thinkpad x230 Built-in Kamera funktioniert nicht

    Kommt auf den Hypervisor an. Bei VMWare kannst du in irgendeinem Menü das Gerät auswählen, was du an den Gast durchreichen willst. In Libvirt/Qemu kannst du das über den Virt-Manager machen. Dazu muss die VM aber ausgeschaltet sein, soweit ich das in Erinnerung hab. Bei VirtualBox weiß ich's nicht mehr genau.
    Für diesen Beitrag bedankt sich Kenobi van Gin

  7. #57
    Brillenschlange

    (Threadstarter)

    Avatar von Kenobi van Gin
    Registriert seit
    Jul 2013
    Ort
    .\
    Beiträge
    3.514
    ngb:news Artikel
    1

    Re: [Xubuntu 18.04.4 LTS] Thinkpad x230 Built-in Kamera funktioniert nicht

    Habe da speziell für VirtualBox was zu gefunden:

    https://www.virtualbox.org/manual/ch...am-passthrough

    Leider bekomme ich bei der Installation des Extension Pack noch eine Fehlermeldung. Aber darum kümmere ich mich nochmal.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •