Ergebnis 1 bis 1 von 1

Thema: Centos 6.9 / 2.6.32 & Touchdevice nur "rechtsklick" und "move" geht

  1. #1

    Centos 6.9 / 2.6.32 & Touchdevice nur "rechtsklick" und "move" geht

    Hi,

    ich habe aktuell ein Problem mit einem Touch an einem "alten" Linux (alte Heizungssteuerung), leider kann ich das Linux nicht Updaten.

    Das Problem ist, dass ich einen (bzw mittlerweile unterschiedliche) Touch an dem Linux getestet habe und irgendwie verhalten sich alle anders aber keiner richtig.

    Die Geräte melden sich alle als generic-usb device hidraw0 USB HID v1.11 Device an (dmesg output). Da diese als HID kommen sollte ich ja erst mal keinen Treiber dafür benötigen, ich habe leider keine weiteren Daten dazu.

    Wenn ich mir die system events ansehe (das Gerät hängt unter /dev/input/event3)
    Code (Bash):
    1. input-events 3
    , dann erhalte ich Sinvolle EV_ABS (ABS_X & ABS_Y) werte, EV_KEY BTN_TOUCH pressed / released je nach dem wo ich halt auf dem Touch bin und ihn betätige oder nicht.
    Es sind also Absolute werte die von dem Touch kommen.
    Code (Bash):
    1.  
    2. bits ev : EV_SYN EV_KEY EV_ABS EV_MSC      
    3.  
    4. waiting for events
    5. 10:18:26.890512: EV_MSC MSC_SCAN 852034
    6. 10:18:26.890516: EV_KEY BTN_TOUCH pressed
    7. 10:18:26.890519: EV_MSC MSC_SCAN 852039  
    8. 10:18:26.890520: EV_KEY BTN_0 pressed    
    9. 10:18:26.890525: EV_ABS ABS_X 431        
    10. 10:18:26.890527: EV_ABS ABS_Y 240        
    11. 10:18:26.890530: EV_MSC MSC_SCAN 852034  
    12. 10:18:26.890531: EV_KEY BTN_TOUCH released
    13. 10:18:26.890582: EV_ABS ??? 0            
    14. 10:18:26.890589: EV_ABS ??? 0            
    15. 10:18:26.890594: EV_ABS ??? 1            
    16. 10:18:26.890596: EV_ABS ??? 55120        
    17. 10:18:26.890602: EV_SYN code=0 value=0    
    18.  

    xinput zeigt mir das Device nur als "Mouse 0" an wenn ich dann in xev das ganze teste sehe ich die Bewegungen und wenn ich mit dem zweiten Finger "touche" dann erhalte ich einen rechts klick (als button 3) , jedoch kein links klick Ereignis.

    In meinem X kann ich den Cursor bewegen nur bekomme ich kein "links klick". Ich mein wenn das bewegen geht, der rechts klick geht (was ja eigentlich nur 2 "touches" sind.. dann muss es doch irgendwie über die xorg config auch gehen, dass der links klick geht oder irre ich mich da?

    Xorg.0.log sagt mir nur :
    Code (Bash):
    1.  
    2. Device "/dev/input/mice"
    3. Mouse0: always reports core events
    4. Option: CorePointer on
    5. Mouse0: mouse protocol ExplorerPS/2
    6. Using input driver "mouse" for Mouse0
    7. ZAxisMapping: buttons 4 and 5 (dies kommt mir komisch vor)
    8. Buttons 9 (dies kommt mir auch komisch vor)
    9.  
    das nächste Kuriose ist, ich habe noch einen zweiten Touch.
    Bei dem Funktioniert der links klick, jedoch kann ich ihn nicht bewegen (obwohl die ABS_X / ABS_Y gleich aussehen).. (wenn ich beide anstecke, kann ich mit dem einen fahren und mit dem anderen klicken ^^).

    der liefert mir :
    Code (Bash):
    1.  
    2. bits ev : EV_SYN EV_KEY EV_ABS EV_MSC      
    3.  
    4. waiting for events
    5. 10:16:49.202491: EV_MSC MSC_SCAN 589825
    6. 10:16:49.202495: EV_KEY BTN_LEFT pressed
    7. 10:16:49.202501: EV_ABS ABS_HAT2X 166  
    8. 10:16:49.202503: EV_ABS ABS_HAT2Y 203  
    9. 10:16:49.205293: EV_SYN code=0 value=0  
    10. 10:16:49.292489: EV_MSC MSC_SCAN 589825
    11. 10:16:49.292494: EV_KEY BTN_LEFT released
    12.  

    Ich hoffe ihr habt mir eine Idee,
    Danke euch
    Geändert von DarkHell (15.05.19 um 08:26 Uhr)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •