Ergebnis 1 bis 5 von 5

Thema: IPv6, ULA, PiHole - sehr große Verwirrung

  1. #1
    LAN-Party Nerd

    Veteran

    Avatar von Localhorst
    Registriert seit
    Nov 2014
    Beiträge
    631
    ngb:news Artikel
    49

    IPv6, ULA, PiHole - sehr große Verwirrung

    Hallo Leute,

    ich bin etwas durcheinander und brauche dafür eure Hilfe!

    Unitymedia bietet nun seit einigen Wochen ECHTES DualStack an und das konnte ich mir nicht nehmen lassen es zu aktiveren. Wer weiß wann es mal nötig ist IPv6 Ready zu sein.

    Jetzt habe ich ein etwas "anderes" Konstrukt in meinem Netzwerk das ich kurz beschreiben möchte:

    Im Einsatz ist eine 6490 Cable und zwei Raspberry Pis mit aktuellem Debian. Die Fritzbox (10.0.7.1/21) ist das Gateway und per DHCP des 1. Pi (10.0.7.2/21) weise ich als DNS Server 10.0.7.2 zu, da dieser ein PiHole ist. Der 2. Rasperry (10.0.7.3/21) ist ein Samba4 Server der mir als Domänencontroller in meinem Netzwerk dient. (Ja ich mache mir das Leben schwer, aber ich wollte PiHole und einen Domänencontroller halt bauen ) Jegliche DNS Anfragen von 10.0.7.2 gehen an 10.0.7.3 die dann anschließend an 1.1.1.1 und 1.0.0.1 aufgelöst werden. Klappt super, ich bin Werbung los und meine ganzen PCs denken sie seien in einer Windows Server 2008R2 Domäne.

    Jetzt kommt ja das DualStack zum Einsatz: Nun habe ich vom UM ja eine IPv6 Adresse bekommen. Frage 1: Wie erhalten denn meine anderen Clients eine v6 Adresse? Dient die Fritzbox als DHCPv6? Im PiHole selber sehe ich unter den DHCP Settings auch noch den Haken: Enable IPv6 support (SLAAC + RA).

    Im PiHole Forum wird dazu geraten eine ULA einzurichten. Jetzt verstehe ich so: dass es dann den Präfix fd:: gibt. Passiert dann aber nicht, dass jedes Gerät intern eine fd:: Adresse bekommt und dadurch NATv6 aktiviert wird, oder verwechsele ich da mehrere Sachen?

    Ich danke euch wirklich für eure Hilfe und merke, ich hätte mich mit IPv6 wesentlich früher beschäftigen sollen ...
    Was, Signatur? Och nee ... Da weiß ich jetzt nicht was ich schreiben soll ...

    Ehemaliger News Redakteur hier im NGB. Abwesenheit hat ihren Preis ;-)

  2. #2
    gesperrt
    Registriert seit
    Feb 2017
    Ort
    deine Mülltonne
    Beiträge
    459
    ngb:news Artikel
    1

    Re: IPv6, ULA, PiHole - sehr große Verwirrung

    @Localhorst: Kannst ja in der Fritzbox IPv6 erst mal deaktiviert lassen, bis du dich besser mit dem Thema auseinander gesetzt hast.

    Zu Beginn kannst du ja mal damit anfangen, wie die Endgeräte bei Ipv6 zu ner IP-Adresse kommen:
    https://de.wikipedia.org/wiki/Neighb...overy_Protocol
    https://de.wikipedia.org/wiki/Dynami...rotocol#DHCPv6
    Für diesen Beitrag bedankt sich Localhorst

  3. #3
    LAN-Party Nerd

    Veteran

    (Threadstarter)

    Avatar von Localhorst
    Registriert seit
    Nov 2014
    Beiträge
    631
    ngb:news Artikel
    49

    Re: IPv6, ULA, PiHole - sehr große Verwirrung

    @nik: Danke dir für die Links! Das hilft mir schonmal sehr weiter.

    Was ich auch gesehen habe ist: Dass ich in der Fritzbox festlegen kann welcher DNS Server bei v6 zu verteilen ist. Als ich ULA fest eingetragen habe stellte ich fest, dass jedes Gerät bei mir im Netzwerk nun 2 IPv6 Adressen hat, die öffentliche und die mit Präfix fd00, bis jetzt hat sich auch an der Performance nichts geändert. Ich beobachte das mal weiter
    Was, Signatur? Och nee ... Da weiß ich jetzt nicht was ich schreiben soll ...

    Ehemaliger News Redakteur hier im NGB. Abwesenheit hat ihren Preis ;-)

  4. #4
    gesperrt
    Registriert seit
    Feb 2017
    Ort
    deine Mülltonne
    Beiträge
    459
    ngb:news Artikel
    1

    Re: IPv6, ULA, PiHole - sehr große Verwirrung

    Sehr gut, dann bist du ja quasi schon durch.

    Inwiefern sollte sich denn die Performance ändern?

  5. #5
    LAN-Party Nerd

    Veteran

    (Threadstarter)

    Avatar von Localhorst
    Registriert seit
    Nov 2014
    Beiträge
    631
    ngb:news Artikel
    49

    Re: IPv6, ULA, PiHole - sehr große Verwirrung

    Mein Kumpel hatte an einem Telekom Anschluss einen Raspberry Pi 1 mit piHole am laufen der IPv4 und v6 filtern sollte. Jedoch sind bei der ersten Anfragen alle DNS Anfragen in ein Timeout gelaufen. Lag daran dass sich der Präfix vom ISP änderte und deshalb keine gültige DNS Antwort möglich war da der PiHole nicht mehr gefunden wurde Es agb da auch diverse andere Berichte in der PiHole Community.
    Was, Signatur? Och nee ... Da weiß ich jetzt nicht was ich schreiben soll ...

    Ehemaliger News Redakteur hier im NGB. Abwesenheit hat ihren Preis ;-)

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •