Ergebnis 1 bis 5 von 5

Thema: minidlna erkennt keine über SMB erstelle Ordner

  1. #1

    minidlna erkennt keine über SMB erstelle Ordner

    Hallo Zusammen,

    ich habe folgendes Linux Setup mir zusammengebaut:

    1 x SSD mit Ubuntu 18.04 LTS Server
    1 x 2 TB Festplatte mit ext4 formatiert

    Auf den Server habe ich den selben Benutzernamen + PW genommen, wie auf meinen Windows Laptop. Dazu noch ein Samba Server und minidlna, beides auf die 2 TB Platte. Der Zugriff funktioniert, wenn ich über SMB einen Ordner erstelle oder Kopiere, dann wird dieser nicht im minidlna aufgeführt. Erstelle ich über die Konsole einen Ordner, dann klappt es.

    Woran liegt das?

    Quick & dirty wäre es die 2 TB mit NTFS zu formatieren, ist das sinnvoll unter Linux?

    lg
    Stone

  2. #2
    Defender of Freedom

    Administrator

    Avatar von Metal_Warrior
    Registriert seit
    Aug 2013
    Ort
    /dev/mapper/home
    Beiträge
    3.225
    ngb:news Artikel
    6

    Re: minidlna erkennt keine über SMB erstelle Ordner

    Zitat Zitat von st0nec0ld Beitrag anzeigen
    Quick & dirty wäre es die 2 TB mit NTFS zu formatieren, ist das sinnvoll unter Linux?
    Nö, ist es nicht. NTFS arbeitet mit Samba auch nicht besser zusammen als ext4, eher schlechter.

    Und was deinen Share angeht: Sind die Ordner, nachdem du sie via Windows erstellt hast, denn auf der Konsole auch sichtbar?
    GCM/IT/S/O d-(--) s+:- a? C++(+++) UL+++(++++)$ P L+++>++++ W++ w@$ M--$ PS+(++) PE(-) Y+(++) PGP++(+++) t+ 5(+) R* !tv b+(++++) DI(++) G++ e+>++++ h(--) y?
    Das Ende ist nahe: Dem Harleyschen Kometen folgt der Gammablitz beim Scheißen.

  3. #3
    Mitglied

    (Threadstarter)

    Avatar von st0nec0ld
    Registriert seit
    May 2017
    Beiträge
    21

    Re: minidlna erkennt keine über SMB erstelle Ordner

    Code (Bash):
    1. stone@L337:~$ ls -la /media/data/Data
    2. drwxrwsr-x  5 stone users       4096 Jun  2 09:10 .
    3. drwxr-xr-x  4 root  root        4096 Mai 28 19:26 ..
    4. drwxrwsr-x  2 stone users       4096 Jun  2 09:10 Ordner_Konsole
    5. drwx--S---  2 stone users       4096 Jun  2 09:09 Ordner_SMB
    Der Ordner ist da, offensichtlich fehlen ein paar Rechte wenn man über SMB erstellt. Ich hatte mit "smbpasswd -a stone" eine Samba User angelegt, dieser scheint nicht ausreichend Rechte zu haben? Liegt es daran?

  4. #4
    Defender of Freedom

    Administrator

    Avatar von Metal_Warrior
    Registriert seit
    Aug 2013
    Ort
    /dev/mapper/home
    Beiträge
    3.225
    ngb:news Artikel
    6

    Re: minidlna erkennt keine über SMB erstelle Ordner

    @st0nec0ld: Du kannst in Samba festlegen, mit welchen Berechtigungen der Ordner und die Dateien darin erstellt werden (Create Directory Mask müsste die Option heißen, und ist - wenn mich nicht mehr alles täuscht - zwingend vierstellig, d. h. 0750 für User rwx und Gruppe r-x). Aktuell erstellt dir Samba das Ding so, dass nur der Besitzer es lesen, sehen und öffnen kann, d. h. wenn dein minidlna jetzt zwar in der Gruppe users drin ist, aber nicht unter dem User stone läuft (was es auch nicht sollte!), dann kann es logischerweise den Ordner nicht lesen.
    Für diesen Beitrag bedanken sich st0nec0ld, nik
    GCM/IT/S/O d-(--) s+:- a? C++(+++) UL+++(++++)$ P L+++>++++ W++ w@$ M--$ PS+(++) PE(-) Y+(++) PGP++(+++) t+ 5(+) R* !tv b+(++++) DI(++) G++ e+>++++ h(--) y?
    Das Ende ist nahe: Dem Harleyschen Kometen folgt der Gammablitz beim Scheißen.

  5. #5
    Mitglied

    (Threadstarter)

    Avatar von st0nec0ld
    Registriert seit
    May 2017
    Beiträge
    21

    Re: minidlna erkennt keine über SMB erstelle Ordner

    Vielen Dank für Hinweis, ich habe mich inzwischen etwas mehr in smb.conf eingelesen und meine nun gepimpt bzw. stark reduziert.
    Code (Bash):
    1. [global]
    2.     workgroup = WORKGROUP
    3.     security = user
    4.     map to guest = never
    5.  
    6. [Data]
    7.     valid users = stone
    8.     path = /media/data
    9.     public = no
    10.     writable = yes
    11.     printable = no
    12.     guest ok = no
    Damit klappt es nun.
    Code (Bash):
    1. stone@L337:~$ ls -la /media/data
    2. drwxrwxr-x  2 stone stone       4096 Jun  6 12:53  ordner_konsole
    3. drwxr-xr-x  2 stone stone       4096 Jun  5 23:53  ordner_smb
    Danke nochmal!

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •