Ergebnis 1 bis 3 von 3

Thema: Mysql Service startet nicht mehr

  1. #1

    Mysql Service startet nicht mehr

    Hallo,
    ich habe hier einen Server, den ich aber nicht aufgesetzt habe und es gibt auch leider keine Dokumentation. Es handelt sich um ein Debian 7 (wheezy), auf dem läuft eine Virtuelle Maschine (VirtualBox, soweit ich das rausfinden konnte). In der Virtuellen Maschine läuft nochmal ein Debian 7.

    Darauf ist ein Apache, PHP5 und Mysql installiert. Der Apache und PHP scheinen zu laufen, ich sehe zumindest eine Ausgabe im Browser. Mit Mysql habe ich erhebliche Problem - wobei am Freitag alles noch lief.
    Beim starten mit `sudo mysqld --verbose` bekomme ich folgende Meldung:

    Code (Bash):
    1.  
    2. 171113 10:03:08 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.
    3. 171113 10:03:08 [Note] mysqld (mysqld 5.5.43-0+deb7u1) starting as process 7602 ...
    4. 171113 10:03:08 [Warning] Can't create test file /var/lib/mysql/wawision.lower-test
    5. 171113 10:03:08 [Warning] Can't create test file /var/lib/mysql/wawision.lower-test
    6. 171113 10:03:08 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.
    7. 171113 10:03:08 [Note] Plugin 'FEDERATED' is disabled.
    8. 171113 10:03:08 InnoDB: The InnoDB memory heap is disabled
    9. 171113 10:03:08 InnoDB: Mutexes and rw_locks use GCC atomic builtins
    10. 171113 10:03:08 InnoDB: Compressed tables use zlib 1.2.7
    11. 171113 10:03:08 InnoDB: Using Linux native AIO
    12. mysqld: Can't create/write to file '/tmp/ibWZMZFO' (Errcode: 30)
    13. 171113 10:03:08  InnoDB: Error: unable to create temporary file; errno: 30
    14. 171113 10:03:08 [ERROR] Plugin 'InnoDB' init function returned error.
    15. 171113 10:03:08 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    16. 171113 10:03:08 [ERROR] Unknown/unsupported storage engine: InnoDB
    17. 171113 10:03:08 [ERROR] Aborting
    18.  
    Soweit ich das verstehe scheitert er also am anlegen einer Datei in /tmp/. Danach scheitert InnoDB. Ich habe gelesen das ich im Ordner `/var/lib/mysql` die Logfiles mal löschen oder umbenennen soll `find /var/lib/mysql -type f -name "ib_logfile?" -exec mv {} {}.bak \;` Dabei bekomme ich aber die Meldung

    Code (Bash):
    1.  Verschieben von „/var/lib/mysql/ib_logfile0“ nach „/var/lib/mysql/ib_logfile0.bak“ nicht möglich: Das Dateisystem ist nur lesbar
    2.  
    .

    Was ist denn hier bitte kaputt? Es wäre nur wichtig, das mysql erstmal wieder startet.

  2. #2
    Mitglied Avatar von phre4k
    Registriert seit
    Mar 2015
    Beiträge
    4.309
    ngb:news Artikel
    2

    Re: Mysql Service startet nicht mehr

    Sieht so aus, als wäre dein Dateisystem nur lesbar eingebunden.

    Schau mal in

    Code (Bash):
    1. mount | grep \(ro
    , das zeigt dir alle nur lesbar eingehängten Geräte an.

    Außerdem mal in die anderen Logfiles, insbesondere die beim Booten angelegten, schauen. Vielleicht geht die Festplatte hopps oder so.

    Wenn man was nicht selbst aufgesetzt hat, ist eine wichtige Sysadmin-Regel, erst mal alles in einen "known state" zu versetzen. Backup und neu aufsetzen wäre hier also die Vorgehensweise nach Lehrbuch.
    *mit Linux wäre das natürlich nicht passiert™
    Arguing that you don't care about the right to privacy because you have nothing to hide is no different than saying you don't care about free speech because you have nothing to say. – Edward Snowden
    kostenloses Webhosting für ngb-Mitglieder
    GCM/S/TW d s+:- a-----? C++$ UL+++$ P-- L+++ E---- W++++ !N ?K w- M-- !P[A-Z] Y++ PGP R* tv-- b++>++++ DI++\:\( G+ e+>++++ h*

  3. #3
    Mitglied

    (Threadstarter)


    Registriert seit
    Jul 2013
    Beiträge
    163

    Re: Mysql Service startet nicht mehr

    Backup ist gezogen, ich werde neu aufsetzten. Habe mir jetzt die komplette VM gezogen und bei mir lokal eingerichtet. Mit `mount -o remount,rw /` konnte ich auf dem System wieder arbeiten.
    Ich spiele jetzt, temporär, in das Hauptsystem ein Apache mit PHP und MySql ein damit die Leute erstmal wieder einsatzfähig sind. Übermorgen bin ich Physisch an dem Server, dann werde ich ihn neu aufsetzten.

    Aber vielen vielen Dank für deine Hilfe

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •