Ergebnis 1 bis 23 von 23

Thema: Fehler: Umleitungsfehler bei Apache Reverse Proxy

  1. #1
    Mitglied
    Registriert seit
    Mar 2020
    Beiträge
    17

    Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Hallo zusammen,

    ich habe auf meinem Raspbery Pi einen Apache Reverse Proxy Server aufgesetzt.
    Ich möchte hier meine zwei Server - Netxcloud und Jitsi Meet von aussen (internet) erreichen.

    Meinen Apache Reverse Proxy Server habe ich so installiert und eingerichtet.

    ## install apache2 ##
    apt-get update
    apt-get install apache2 -y

    ## enable moduls ##
    a2enmod proxy
    a2enmod proxy_http
    a2enmod proxy_ajp
    a2enmod rewrite
    a2enmod deflate
    a2enmod headers
    a2enmod proxy_balancer
    a2enmod proxy_connect
    a2enmod proxy_html
    service apache2 restart

    ## create config for 1st client ##
    nano /etc/apache2/sites-enabled/server1.conf

    <VirtualHost *:80>
    ServerName subdomain11.yourdomain.com
    ProxyPreserveHost On
    DocumentRoot /var/www/html
    ProxyPass /.well-known !
    ProxyPass / http://10.1.1.11:80/
    ProxyPassReverse / http://10.1.1.11:80/
    </VirtualHost>

    ## create config for 2nd client ##
    nano /etc/apache2/sites-enabled/server2.conf
    <VirtualHost *:80>
    ServerName subdomain12.yourdomain.com
    ProxyPreserveHost On
    DocumentRoot /var/www/html
    ProxyPass /.well-known !
    ProxyPass / http://10.1.1.12:80/
    ProxyPassReverse / http://10.1.1.12:80/
    </VirtualHost>

    ## restart apache server ##
    service apache2 restart

    ## install Let's Encrypt Certbot ##
    apt-get install python-certbot-apache

    ## create certificates ##
    certbot --apache

    #--> certificate only lasts 90 days

    #install crontab
    crontab -e

    0 1 * * * /usr/bin/certbot renew & > /dev/nul
    Natürlich habe ich die /etc/apache2/sites-enabled/server1.conf und /etc/apache2/sites-enabled/server2.conf auf meine Dyndns Adressen angepasst und meine Lokalen IP eingetragen.

    Die ssl Zertifizierung sollte für beide Domains auch funktionieren.
    Please choose whether or not to redirect HTTP traffic to HTTPS, removing HTTP access.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    1: No redirect - Make no further changes to the webserver configuration.
    2: Redirect - Make all requests redirect to secure HTTPS access. Choose this for
    new sites, or if you're confident your site works on HTTPS. You can undo this
    change by editing your web server's configuration.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Select the appropriate number [1-2] then [enter] (press 'c' to cancel): 2
    Redirecting vhost in /etc/apache2/sites-enabled/server1.conf to ssl vhost in /etc/apache2/sites-enabled/server1-le-ssl.conf
    Redirecting vhost in /etc/apache2/sites-enabled/server2.conf to ssl vhost in /etc/apache2/sites-enabled/server2-le-ssl.conf

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Congratulations! You have successfully enabled https://.dyndns.org and
    https:/mine.nu
    Beispiel von mir:
    /etc/apache2/sites-enabled/server2.conf

    <VirtualHost *:80>
    ServerName videomeet.dyndns.org
    ProxyPreserveHost On
    DocumentRoot /var/www/html
    ProxyPass /.well-known !
    ProxyPass / http://192.168.0.50:80/
    ProxyPassReverse / http://192.168.0.50:80/
    RewriteEngine on
    RewriteCond %{SERVER_NAME} =videomeet.dyndns.org
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    </VirtualHost>

    Ich habe in meiner Fitzbox die Ports 443 und 80 auf den pi weitergeleitet.
    Rufe ich meine Seite aber über das Internet auf erhalte ich diese Meldungen:

    Fehler: Umleitungsfehler
    Beim Verbinden mit domain.dyndns.org trat ein Fehler auf.
    Dieses Problem kann manchmal auftreten, wenn Cookies deaktiviert oder abgelehnt werden
    Ich habe die Cookies gelöscht von unterschiedlichen Rechner und Netzten probiert, leider bleibt diese Meldung.
    Was kann ich machen? Kann mir einer behilflich sein.
    Gruß
    Geändert von Lock (14.11.20 um 16:51 Uhr)

  2. #2
    Mitglied
    Registriert seit
    Jul 2013
    Ort
    /dev/null
    Beiträge
    2.868

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Was meint denn das Apache-Log (/var/log/apache2/)?
    Für diesen Beitrag bedankt sich Lock

  3. #3
    Mitglied

    (Threadstarter)


    Registriert seit
    Mar 2020
    Beiträge
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Hallo @musv

    danke für deine Antwort.
    Ich habe die log die in (/var/log/apache2/) einmal hochgeladen.

    other_vhosts_access.log
    http://paste.ubuntu.com/p/kBXjqh472P/

    access.log
    http://paste.ubuntu.com/p/VjwYzP3nzv/

    error.log
    http://paste.ubuntu.com/p/N8NbBMxvRB/

    Eventuell findest du etwas.
    VG

  4. #4
    0.938 GeV
    Registriert seit
    Jul 2018
    Beiträge
    86

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Der Browser will dir vermutlich sagen, dass deine Site eine Umleitungsschleife hat - du also eine URL immer wieder auf sich selbst umleitest.
    Auf die Schnelle haette ich
    Code:
    RewriteEngine on
    RewriteCond %{SERVER_NAME} =videomeet.dyndns.org
    RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    im Verdacht.
    Steckt das auch in der VirtualHost-Config fuer TLS, also "*:443"? Dort waer's verkehrt.

    Ausserdem - wenn du eh schon alles von HTTP weg nach HTTPS umleitest (was an sich ja gut ist), kannst du dir die ganze uebrige Konfiguration im HTTP-VirtualHost (also ProxyPass etc.) auch sparen.
    We do what we must, because we can.

  5. #5
    Defender of Freedom

    Administrator

    Avatar von Metal_Warrior
    Registriert seit
    Aug 2013
    Ort
    /dev/mapper/home
    Beiträge
    6.244
    ngb:news Artikel
    7

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Mal ne doofe Frage: Sind die anderen zwei Server andere Maschinen?

    Wenn ja, musst du Proxyrules einrichten, korrekt. Dann aber entweder Rewrites oder Proxy, nicht beides zusammen. Außerdem: die sites-enabled ist eigentlich ein technisches Directory, man arbeitet grundsätzlich in sites-available und enabled dann via a2ensite die entsprechende Config (damit kann man schnell wieder zurück, wenn eine Config den Apachen kaputt schießt, und man den Fehler nicht auf die Schnelle findet).

    Wenn das auf der gleichen Maschine ist, braucht es keinen Proxy. Umleitung via HTTP 301 genügt dann völlig. Man muss nur den Port am Router freischalten.
    GCM/IT/S/O d-(--) s+:- a? C++(+++) UL+++(++++)$ P L+++>++++ W++ w@$ M--$ PS+(++) PE(-) Y+(++) PGP++(+++) t+ 5(+) R* !tv b+(++++) DI(++) G++ e+>++++ h(--) y?
    Das Ende ist nahe: Dem Harleyschen Kometen folgt der Gammablitz beim Scheißen.

  6. #6
    Zeitreisender

    Administrator

    Avatar von drfuture
    Registriert seit
    Jul 2013
    Ort
    in der Zukunft
    Beiträge
    7.042
    ngb:news Artikel
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Und Tests von Seiten die extern erreichbar sein sollten bitte immer mit dem Handy ohne WLAN machen.
    Laut den logs kommen ja zumindest anfragen an, wobei du neben vhost in ein eigenes Log schreiben solltest

    Die Fritzbox leitet Anfragen an das eigene Netz meist erstmal nicht über die externe Schnittstelle was zu unerwarteten Ergebnissen führen kann
    |_|D *`~{ Ich kenne deine Zukunft }~´* |_|D

  7. #7
    Mitglied
    Registriert seit
    Jul 2013
    Ort
    /dev/null
    Beiträge
    2.868

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Zitat Zitat von Metal_Warrior Beitrag anzeigen
    Wenn das auf der gleichen Maschine ist, braucht es keinen Proxy. Umleitung via HTTP 301 genügt dann völlig. Man muss nur den Port am Router freischalten.
    Ist bei uns allerdings ein Standardvorgehen. Wir klemmen vor jeden Webservice (Tomcat, Glassfish, u.a.) einen Apache. Hat die Vorteile:
    • Standardisierte Zertifikatsinstallation. Bei anderen Webdiensten müssten wir dann die unterschiedlichen Configs erst durcharbeiten
    • Verwendung Port 443: Unsere firmeninternen Firewalls mögen keine abweichenden Ports. Genauso sind aus dem Firmennetzwerk auch keine Internetseiten erreichbar, die auf anderen Ports laufen.
    • Zugriffskontrolle per LDAP, Kerberos, AD: Auch das frühstücken wir über den vorgeschalteten Apache als Proxy ab.



    Zitat Zitat von Lock Beitrag anzeigen
    Code:
    RewriteCond %{SERVER_NAME} =videomeet.dyndns.org
    https://httpd.apache.org/docs/2.4/mo...ml#rewritecond
    Ich finde da nirgendwo ein =.


    Was mich in den Logs stutzig macht:
    Da tauchen die Fehler 302 und 400 auf. Metal_Warrior hat's auch schon erwähnt. Sofern die 192.168.0.50 auf demselben Server liegt wie der Apache, kommt der Server ja gar nicht aus der Umleitung raus. D.h. du schickst den beim Aufruf von Port 80 immer wieder in dieselbe VHost-Sektion rein. Der kommt gar nicht erst bis zum Proxy Pass. Deswegen wär's interessant zu wissen, von welchen IPs auf welche der Proxy funktionieren soll.
    Geändert von musv (16.11.20 um 13:48 Uhr)

  8. #8
    Mitglied

    (Threadstarter)


    Registriert seit
    Mar 2020
    Beiträge
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Hallo zusammen,

    danke erstmals das ihr euch dieses Thema annimmt.
    Ich beschreibe am besten Erstmal mein Netzwerk.
    • Router ist eine Fritzbox mit der IP 192.168.0.1
    • Der Apache Reverse Proxy läuft auf einem Raspberry PI mit der IP 192.168.0.38
    • Der Jitsi Server läuft auf einem Debian 10 mit der IP: 192.168.0.50
    • Nextcloud läuft auf einem Raspberry PI mit der IP: 192.168.0.70



    Also alle Geräte laufen auf eigenen Maschinen.

    Ich bin wie im ersten Post vorgegangen und habe nach dieser Anleitung gearbeitet.


    Ich habe unter /etc/apache2/sites-enabled/server2.conf
    diesen Eintrag:
    Code (Apache/.htaccess):
    1. <VirtualHost *:80>
    2. ServerName videomeet.mine.nu
    3. ProxyPreserveHost On
    4. DocumentRoot /var/www/html
    5. ProxyPass /.well-known !
    6. ProxyPass / [url]http://192.168.0.50:80/[/url]
    7. ProxyPassReverse / [url]http://192.168.0.50:80/[/url]
    8. RewriteEngine on
    9. RewriteCond %{SERVER_NAME} =videomeet.mine.nu
    10. RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    11. </VirtualHost>
    Code (Apache/.htaccess):
    1.  
    2. RewriteEngine on
    3. RewriteCond %{SERVER_NAME} =videomeet.mine.nu
    4. RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    Diese Einträge stammen von certbot --apache

    Da ich, wie auch schon festgestellt wurde, alle Einträge über https laufen lassen möchte habe ich mich auch nach dem Sinn der oberen Eintragung gefragt und eine
    neue server4.conf erstellt.

    Code (Apache/.htaccess):
    1. <VirtualHost *:443>
    2. ServerName lock.dyndns.org
    3. ProxyPreserveHost On
    4. DocumentRoot /var/www/html
    5. ProxyPass /.well-known !
    6. ProxyPass / http://192.168.0.70:443/
    7. ProxyPassReverse / http://192.168.0.70:443/
    8. RewriteEngine on
    9. RewriteCond %{SERVER_NAME} =lock.dyndns.org
    10. RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    11. </VirtualHost>
    aber auch dieser leitete nicht weiter.

    Ich habe auf Jitsi Meet und dem Netxcloud bereits Zertifikate über cerbot erstellt.
    Zum einen frage ich mich, wie ich ob ich mehrere Zertifikate auf eine IP nutzen kann zum anderen stellt sich für mich die Frage, wo ich die Zertifikate erstellen soll, auf dem Gerät (also Jitsi / Netxcloud) oder auf dem Apache.

    Ist es eventuell besser mit einem Nginx Proxy Manager mit GUI zu arbeiten?

    Ich hoffe ich konnte euch weitere Infos geben und ihr könnt meine Fragen beantworten.

    Gruß Lock

  9. #9
    Zeitreisender

    Administrator

    Avatar von drfuture
    Registriert seit
    Jul 2013
    Ort
    in der Zukunft
    Beiträge
    7.042
    ngb:news Artikel
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Eine Gui behebt nicht das Problem das man verstehen muss was man machen möchte... im Gegenteil - das verstärkt das Problem eher.

    Ich kenne nun leider den Syntax für Apache als ReverseProxy nicht - da ich in der Tat für alles grunsätzlich Nginx verwende.
    Aber das du "alles" auf eine IP weiterleitest macht so keinen Sinn.

    Was möchtest du denn erreichen? Beide Dienste auf deiner IP zu betreiben.. soweit so klar...
    Aufruf über eine Subdomain oder über einen Teil der URL?

    1. Der Client "verbindet" sich mit der Fritzbox.
    2. Die Fritzbox leitet Anfragen auf Port 80 + 443 an den Raspi, dort wartet ein Dienst der die Frage entgegen nimmt, dieser benötigt nun ein SSL-Zertifikat für die Verbindung Raspi <-> Client. Passend für die jeweilige(n) Domain(s).
    3. Der Dienst auf dem Raspi baut dann innerhalb deines Netzwerks eine Verbindung zum anderen PC / Raspi auf und ruft dort Infos ab. Hier kannst du dir dann überlegen ob du das wieder über SSL machst oder ohne. So oder so benötigt dann dort, wenn du über https gehst, erneut die jeweiligen Zertifikate auf den Zielsystemen. Wichtig ist das der Reverse-Proxy die Verbindung Terminiert und nicht "Durchleitet".
      Ebenso müssen auch Rewrite-Geschichten überdacht werden. Es bringt nicht viel url-Rewrites an allen ecken und Enden umzusetzen.
      Eventuell bringt das Rewrite oben nach der Weiterleitung an die proxy-Adresse auch nichts mehr? (Wie gesagt kenne hier die Verarbeitung nicht).


    Die Konfiguration muss jedenfalls so lauten das der Reverse-Proxy weiß was er bei Aufruf von hostname 1 machen soll und was bei hostname 2 - beide können dabei natürlich auf einer IP laufen. Ein VHOST mit *:80 heißt hier aber das bei beiden Hostnamen immer das gleiche passiert.
    |_|D *`~{ Ich kenne deine Zukunft }~´* |_|D

  10. #10
    Mitglied

    (Threadstarter)


    Registriert seit
    Mar 2020
    Beiträge
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Hallo,

    ich möchte folgendes erreichen.

    Ich habe z.Z. zwei Dyndns Adressen.

    Beispiel:

    jitis.dyndns.org
    und
    nextcloud.dyndns.org

    Diese beiden Adressen möchte ich so weiterleiten, dass ich diese vom Internet aus erreichen kann.
    Da beide den Port 80 und 443 verwenden ist mein Router hier überfordert, er kann nur an eine IP weiterleiten.

    Deshalb wollte ich einen Reverse Proxyn aufsetzten.

    Dazu habe ich wie in der Anleitung im ersten Post diesen erstellt.

    Um eine Weiterleitung zu erreichen habe ich mehrere
    /etc/apache2/sites-enabled/server1.conf
    erstellt.

    Beispiel:
    /etc/apache2/sites-enabled/server1.conf

    Code (Apache/.htaccess):
    1.   <VirtualHost *:80>
    2.     ServerNamej itsie.dyndns,org
    3.     ProxyPreserveHost On
    4.     DocumentRoot /var/www/html
    5.     ProxyPass /.well-known !
    6.     ProxyPass / [url]http://192.168.0.50:80/[/url]
    7.     ProxyPassReverse / [url]http://192.168.0.50:80/[/url]
    8.     RewriteEngine on
    9.     RewriteCond %{SERVER_NAME} =itsie.dyndns,org
    10.     RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    11.     </VirtualHost>
    und
    /etc/apache2/sites-enabled/server2.conf

    mit diesem Inhalt:

    Code (Apache/.htaccess):
    1.  <VirtualHost *:80>
    2.     ServerName nextcloud.dyndns.org
    3.     ProxyPreserveHost On
    4.     DocumentRoot /var/www/html
    5.     ProxyPass /.well-known !
    6.     ProxyPass / [url]http://192.168.0.70:80/[/url]
    7.     ProxyPassReverse / [url]http://192.168.0.70:80/[/url]
    8.     RewriteEngine on
    9.     RewriteCond %{SERVER_NAME} =nextcloud.dyndns.org
    10.     RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    11.     </VirtualHost>
    dadurch will ich erreichen, wenn ich aus dem Internet auf

    nextcloud.dyndns.org zugreife komme ich auf meine nextcloud
    und wenn ich auf
    ijtsie.dyndns,org zugreife komme ich auf den jitsi Server.

    Meine Frage geht auf die Syntac
    Laut Beschreibung habe ich

    Code (Apache/.htaccess):
    1.  <VirtualHost *:80> ---- ist hier nicht Port 443 richtig
    2.     ServerName nextcloud.dyndns.org
    3.     ProxyPreserveHost On
    4.     DocumentRoot /var/www/html
    5.     ProxyPass /.well-known !
    6.     ProxyPass / [url]http://192.168.0.70:80/[/url] ---- ist hier nicht Port 443 richtig
    7.     ProxyPassReverse / [url]http://192.168.0.70:80/[/url] ---- ist hier nicht Port 443 richtig
    8.     RewriteEngine on
    9.     RewriteCond %{SERVER_NAME} =nextcloud.dyndns.org
    10.     RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
    11.     </VirtualHost>
    Eventuell kann mir hier einer weiterhelfen und ich hoffe ich habe meine Wünsche jetzt einigermassen deutlich formuliert ;-)

    Gruß Lock

  11. #11
    Mitglied
    Registriert seit
    Jul 2013
    Ort
    /dev/null
    Beiträge
    2.868

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Ja, ist verständlich formuliert. Was wir oben schon ein paar mal geschrieben haben, hast du noch immer nicht korrigiert.



    Zitat Zitat von Lock Beitrag anzeigen
    Um eine Weiterleitung zu erreichen habe ich mehrere /etc/apache2/sites-enabled/server1.conf erstellt.
    S.o. das kommt nicht in sites-enabled sondern in sites-available rein und wird dann rübergelinkt.

    Zitat Zitat von Lock Beitrag anzeigen
    Code (Apache/.htaccess):
    1.   <VirtualHost *:80>
    2.     ServerNamej itsie.dyndns,org
    3.     ProxyPreserveHost On
    4.     DocumentRoot /var/www/html   # eigentlich auch sinnlos, da du alles per Proxy weiterschickst.
    5.     ProxyPass /.well-known !         # wozu?
    6.     ProxyPass / [url]http://192.168.0.50:80/[/url]     # sind die url-Tags vom Forum? Die sind da falsch.
    7.     ProxyPassReverse / [url]http://192.168.0.50:80/[/url]  # falsche url-Tags
    8.     RewriteEngine on                        # eigentlich sinnlos, da du sowieso alles bis auf die .well-known an die .50 weiterleitest.
    9.     RewriteCond %{SERVER_NAME} =itsie.dyndns,org  # sinnlos + siehe oben, das = steht nicht in der Apache-Doku
    10.     RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]    # sinnlos.
    11.     </VirtualHost>
    Wenn auch https verwendet wird, musst du noch einen VirtualHost für Port 443 definieren. Jetzt ist die Frage, ob Jitsi und Nextcloud wie wild zwischen http oder https wechseln. Falls nicht, würde ich intern rein auf http setzen.

    Also Minimalbeispiel für Dein Jitsi:
    Code (Apache/.htaccess):
    1.  
    2. <VirtualHost *:80>
    3.     ServerNamej itsie.dyndns,org
    4.     ProxyPreserveHost On
    5.     ProxyPass / http://192.168.0.50:80/  
    6.     ProxyPassReverse / http://192.168.0.50:80/
    7. </VirtualHost>
    8.  
    9. <VirtualHost *:443>
    10.     ServerNamej itsie.dyndns,org
    11.     ProxyPreserveHost On
    12.     ProxyPass / http://192.168.0.50:80/  
    13.     ProxyPassReverse / http://192.168.0.50:80/
    14. </VirtualHost>
    15.  
    Probier aus, ob das läuft und leg dann ggf. noch die beiden VirtualHost-Sektionen für nextcloud an. Und wenn du von außen nur https zulässt, kannst du Dir sogar noch den ersten VirtualHost-Block sparen.

  12. #12
    Mitglied

    (Threadstarter)


    Registriert seit
    Mar 2020
    Beiträge
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Hallo,

    danke für die Hilfestellung und den wichtigen Hinweis mit

    /etc/apache2/sites-available

    Ich habe jetzt die Inhalte von sites-enabled nach etc/apache2/sites-available kopiert.
    Danach habe ich den Apache neu gestartet.
    Leider brachte das keinen Erfolg.

    Ich habe dann die server1.conf bearbeitet.

    Code (Apache/.htaccess):
    1. <VirtualHost *:80>
    2.     ServerName videomeet.mine.nu
    3.     ProxyPreserveHost On
    4.     ProxyPass / http://192.168.0.50:80/
    5.     ProxyPassReverse / http://192.168.0.50:80/
    6. </VirtualHost>
    7.  
    8. <VirtualHost *:443>
    9.     ServerName videomeet.mine.nu
    10.     ProxyPreserveHost On
    11.     ProxyPass / http://192.168.0.50:443/              -----Hier habe ich die Ports auf 443 gestellt
    12.     ProxyPassReverse / http://192.168.0.50:443/ -----Hier habe ich die Ports auf 443 gestellt
    13. </VirtualHost>
    14.  
    Apache neu gestartet, leider ohne Erfolg.
    Ich teste meine Webseiten immer über diese Seite
    http://free-website-translation.com/?de
    dann werden meine Seiten von ausserhalb aufgerufen.

    Hier erhalte ich die Meldung:

    Die angefragte Seite hat eine Weiterleitung zu sich selbst versucht, was zu einer Endlosschleife führen könnte.

    Kann hier was falsch sein, weil beide auf die gleiche
    Zitat Zitat von musv Beitrag anzeigen
    S.o. das kommt nicht in sites-enabled sondern in sites-available rein und wird dann rübergelinkt.
    IP Linken.
    ProxyPass / http://192.168.0.50:80/
    ProxyPassReverse / http://192.168.0.50:80/


    S.o. das kommt nicht in sites-enabled sondern in sites-available rein und wird dann rübergelinkt.

    Reicht hier das Kopieren, oder muss ich was anderes beachten.


    Beste Grüße Lock

  13. #13
    Zeitreisender

    Administrator

    Avatar von drfuture
    Registriert seit
    Jul 2013
    Ort
    in der Zukunft
    Beiträge
    7.042
    ngb:news Artikel
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Mit Link ist ein Symbolischer Link gemeint "ln -s ..... ".

    Die Weiterleitung kann gut und gerne auch von der Webanwendung selbst kommen - das heißt dein Reverse-Proxy würde funktionieren.
    Zum Testen von etwas bitte am besten immer die minimalste komplexität verwenden die für das zu testende Szenario notwendig ist.

    Im deinem jetzigen Aufbau kannst du unmöglich feststellen wo der Fehler liegt.

    - Eventuell reagiert die "Free-website-Translation" Seite komisch bei dyndns Adressen?
    - Eventuell ist Nextcloud / Jitsi falsch konfiguriert?
    - Eventuell passt der Reverse-Proxy nicht?
    - Vielleicht passt auch der Apatche von Nextcloud nicht...?

    Um festzustellen das zumindest die Webserver korrekt funktionieren würde ich im Grunde sogar ohne SSL arbeiten.

    Das heißt auf einem System, z.B. das mit Nextcloud einen vhost mit einem leeren Basisverzeichnis einrichten der auf nextcloud.dyndns.org hört.
    In das Verzeichnis kommt dann eine index.html in der einfach nur "Hallo ich bin`s die Nexcloud-Seite" ... steht.
    Dann gehst du, wie oben vorgeschlagen, mit dem Handy übers Mobilfunknetz oder du machst einen Hotspot auf und gehst mit dem Laptop darüber auf die Seite und schaust was passiert.

    Mir fallen in jedem Fall ohne Test 2 Fehler auf:

    - Bei der SSL-Konfiguration (Daher wäre ein Test ohne erst einmal besser) am Reverse Proxy fehlt die Definition des SSL-Zertifikats on SSL-On

    SSLEngine on
    SSLCertificateFile /---/public.pem
    SSLCertificateKeyFile /---/privkey.pem
    SSLCertificateChainFile /---/chain-class2.pem
    Wie oben beschrieben ruft der Reverse-Proxy die Seiten des internen Webservers von z.B. Nextcloud ab. Daher ist dann die Aufrufende URL auch nicht mehr "nextcloud.dyndns.org" sondern laut Doku ein Eintrag aus der Proxypass-Direktive ... leider steht in der Doku nicht so wirklich was genau?
    Alternativ kann "ProxyPreserveHost On" gesetzt werden damit der von extern kommende Hostname im Header an den internen Server weitergegeben wird.
    Für diesen Beitrag bedankt sich Lock
    |_|D *`~{ Ich kenne deine Zukunft }~´* |_|D

  14. #14
    Mitglied
    Registriert seit
    Jul 2013
    Ort
    /dev/null
    Beiträge
    2.868

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Zitat Zitat von Lock Beitrag anzeigen
    /etc/apache2/sites-available

    Ich habe jetzt die Inhalte von sites-enabled nach etc/apache2/sites-available kopiert.
    Nicht kopieren sondern verschieben.
    Code (Bash):
    1. cd /etc/apache2/sites-enabled
    2. mv * ../sites-available/
    3. cd ../sites-available
    4. ln -s ../site-enabled/*
    Das ist übrigens die Debian-Syntax. Andere Distributionen arbeiten nicht mit sites-available usw. Das Ganze hat den Sinn, dass du VHosts nach Lust und Laune konfigurieren, die aber gezielt aktivieren und deaktivieren kannst. In irgendeiner Apache-Config-Datei werden dann alle Configs aus /etc/apache2/sites-enabled geparst.

    Im Grunde genommen hat damit Deine ursprüngliche Konfiguration schon soweit funktioniert, dass die Vhosts eingelesen wurden. Es war halt nur etwas ungünstig platziert.

    Zitat Zitat von Lock Beitrag anzeigen
    Ich habe dann die server1.conf bearbeitet.

    Code (Apache/.htaccess):
    1. <VirtualHost *:443>
    2.     ServerName videomeet.mine.nu
    3.     ProxyPreserveHost On
    4.     ProxyPass / http://192.168.0.50:443/              -----Hier habe ich die Ports auf 443 gestellt
    5.     ProxyPassReverse / http://192.168.0.50:443/ -----Hier habe ich die Ports auf 443 gestellt
    6. </VirtualHost>
    7.  
    Ich hatte da bewusst die 80 verwendet. Ich glaub, du hast das Prinzip nicht nicht ganz verstanden.

    Code (Apache/.htaccess):
    1. <VirtualHost *:443>      #Dein Apache hört auf alle Anfragen auf Port 443
    2.     ServerName videomeet.mine.nu    # Wenn im HTTP-Header der Server videomeet.mine.nu aufgerufen wurde, hast du hier einen Match
    3.     ProxyPreserveHost On              # videomeet.mine.nu bleibt im HTTP-Header erhalten als Anfrager.
    4.     ProxyPass / http://192.168.0.50:80   # Die Anfrage wird dann intern an die 192.168.0.50 auf Port 80 weitgerleitet.
    5.     ProxyPassReverse / http://192.168.0.50:80 # Und was von der .50 zurückkommt wird wieder nach draußen geschickt.
    6. </VirtualHost>
    7.  
    Intern ist Port 80 erst mal sinnvoller. Ansonsten müsstest du ein SSL-Zertifikat auf dem Webserver von 192.168.0.50 konfiguriert haben. Bei Port 80 sparst du Dir das.

    Der Unterschied zwischen ProxyPass und Redirect (RewriteRule) ist:
    Beim Redirect wird die Anfrage an eine neue URL umgeleitet. Der Aufrufer der URL bekommt das auch mit. D.h. im Browser ändert sich die URL. Beim ProxyPass leitet der Apache intern die Anfrage an eine andere Applikation, einen anderen Port oder eine andere Adresse weiter. Der Aufrufer der URL bekommt das aber nicht mit. Er sieht nur den Apache auf Port 80 oder 443 (was im VirtualHost konfiguriert ist). Wie ich bereits oben mal erwähnt hab, verwenden wir ProxyPass ziemlich ausgiebig in der Arbeit, um lokale Tomcats, Glassfische oder andere Application Server abzuschotten. Über den Apache konfigurieren wir den Zugang per HTTPS mit Zertifikat auf Port 443 und eventuell noch LDAP-Authentifizierung. Und hinter der lokalen Firewall verborgen arbeitet der Application Server, der nur über Localhost durch den Apache erreicht werden kann. Hat den Vorteil, dass wir ein mit Templates standardisiertes Vorgehen haben und uns die lokale Anwendung ziemlich egal ist.

    Und wie DrFuture schon mal geschrieben hat, solltest du erst mal das komplexe Gebilde auf die einzelnen Schritte runterbrechen. D.h. sinnvoll wäre erst mal der Check, ob die Webanfrage auf der 192.168.0.38 ankommt. Dazu kommentierst du mal das ProxyPass aus und legst eine index.html mit Hallo ins DocumentRoot
    Code (Apache/.htaccess):
    1. <VirtualHost *:443>
    2.   ServerName videomeet.mine.nu
    3.   DocumentRoot=/var/www/html
    4. </VirtualHost>
    5.  
    6. <Directory /var/www/html>
    7.     Options Indexes
    8.     AllowOverride None
    9.     Require all granted
    10. </Directory>
    Und in /var/www/html legst du eine index.html mit "hallo" an.

    Wenn das klappt, weißt du schon mal, dass der Raspi von außen erreichbar ist über https. Dann kannst du den o.g. VHost wieder verwenden mit dem ProxyPass. Auf der 192.168.0.50 lässt du mal einen tcpdump laufen, d.h.
    Code (Bash):
    1. tcpdump -v -i eth0 host 192.168.0.38 and port 80
    Wenn beim Aufruf der Adresse von außen, dann das tcpdump fleißig Nachrichten schreibt, weißt du, dass auch diese Verbindung (außen -> Raspi -> jitsi-Server) klappt.
    Für diesen Beitrag bedankt sich Lock
    Geändert von musv (18.11.20 um 15:40 Uhr)

  15. #15
    Mitglied

    (Threadstarter)


    Registriert seit
    Mar 2020
    Beiträge
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Hallo zusammen,

    erst mal vielen Dank das ihr so geduldig mit mir seid.

    Ich hoffe das ich eure Anweisung richtig verstanden habe und beschreibe einmal was ich gemacht habe.

    Habe das ausgeführt:
    Code (Bash):
    1.     cd /etc/apache2/sites-enabled
    2.     mv * ../sites-available/
    3.     cd ../sites-available
    4.     ln -s ../site-enabled/*


    unter
    /etc/apache2/sites-available
    habe ich die server1.conf erstellt
    mit diesem Inhalt.

    Code (Apache/.htaccess):
    1.  <VirtualHost *:443>
    2.       ServerName videomeet.mine.nu
    3.       DocumentRoot=/var/www/html
    4.     </VirtualHost>
    5.  
    6.     <Directory /var/www/html>
    7.         Options Indexes
    8.         AllowOverride None
    9.         Require all granted
    10.     </Directory>
    Danach habe ich den Apache neu gestartet.


    service apache2 restart


    Unter
    /var/www/html
    liegt schon eine index,html deshalb habe ich keine neue erstellt.

    Von einem anderen Debian System im LAN habe ich dann das ausgeführt und leider nur das erhalten:

    tcpdump -v -i eth0 host 192.168.0.38 and port 80
    Code (Bash):
    1. tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
    Von ausserhalb komme ich auch nicht auf
    videomeet.mine.nu/

    In der Fritzbox habe ich diese Port weitergeleitet an den Proxy:
    raspberrypi
    192.168.0.38
    HTTPS-Server
    HTTP-Server
    443
    80

  16. #16
    Defender of Freedom

    Administrator

    Avatar von Metal_Warrior
    Registriert seit
    Aug 2013
    Ort
    /dev/mapper/home
    Beiträge
    6.244
    ngb:news Artikel
    7

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Ich probiers jetzt mal anders (nachdem ich Jitsi auch schon aufgesetzt hab und der mitunter eventuell eh deinen Proxy zerschießt, ist das vielleicht so rum sinnvoller):

    Auf deinem Jitsi-Server deaktivierst du bitte die Jitsi-Config. Nur noch die 000-default.conf aktiv lassen. Das überprüfst du bitte, indem du den Server aus dem internen Netz aufrufst. Meldet sich da Debian mit seiner "It Works!"-Seite, bist du an der Stelle schonmal richtig.

    Deinem HTTP- und HTTPS-Server, den du ja als Proxy nutzen möchtest, spendierst du bitte eine feste IP. Ob du das mit deinem Router anstellst oder den Server selbst vom DHCP abklemmst und per Static IP konfiguriest, ist egal. Wichtig ist nur, dass er nicht auf blöd mal ne andere IP bekommen kann. Anschließend leitest du genau Port 80 und Port 443 auf diese IP weiter.

    Mit deinen anderen zwei Servern verfährst du bitte ebenso. Feste IPs. Egal wie. Nichts ist ärgerlicher, als Umleitungen ins Nichts.

    Anschließend erstellst du auf deinem HTTP-Server eine Config in sites-available, die nichts anderes tut als eine Umleitung von Port 80 auf Port 443 und nennst sie http.conf:

    Code (Apache/.htaccess):
    1. <VirtualHost *:80>
    2.   RewriteEngine on
    3.   RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [NC,R,L]
    4.   Errorlog ${APACHE_LOG_DIR}/http_error.log
    5.   Customlog ${APACHE_LOG_DIR}/http_access.log combined
    6. </VirtualHost>
    Damit wird jetzt ALLES, egal von woher, erstmal auf HTTPS gezogen. Damit merzen wir mal eine Fehlerquelle aus. Du deaktivierst bitte mit a2dissite alle Sites. Alle. Es darf kein Link und keine Datei mehr in sites-enabled sein. Anschließend tippst du

    Code (Bash):
    1. sudo a2ensite http.conf
    2. sudo systemctl restart apache2
    Rufst du jetzt die Seite (von intern oder extern auf, MUSS ein "Server antwortet nicht" auf HTTPS kommen. Kommt das nicht, hast du woanders was vergurkt.
    Kommt es aber, machen wir weiter:
    Neue Config in sites-available, diesmal nennst du sie https.conf:

    Code (Apache/.htaccess):
    1. <VirtualHost *:443>
    2.   ServerName DEINEDOMAIN.TLD
    3.   DocumentRoot /var/www/html
    4.  
    5.   SSLEngine on
    6.   SSLCertificateFile /etc/ssl/certs/ssl-cert-snakeoil.pem
    7.   SSLCertificateKeyFile /etc/ssl/private/ssl-cert-snakeoil.key
    8.  
    9.   Errorlog ${APACHE_LOG_DIR}/https_error.log
    10.   Customlog ${APACHE_LOG_DIR}/https_access.log combined
    11. </VirtualHost>
    Anschließend wieder:
    Code (Bash):
    1. sudo a2ensite https.conf
    2. sudo systemctl restart apache2
    Jetzt solltest du eine Zertifikatswarnung bekommen (weil das die Snakeoil-Zertifikate sind, die Debian am Anfang generiert) und wenn du das Risiko akzeptierst, die schnuckelige Debian-"It Works!"-Seite vom Apachen. Wenn bis dahin alles geklappt hat, können wir weiter machen. Erstmal aber soweit kommen.
    Für diesen Beitrag bedankt sich Lock
    Geändert von Metal_Warrior (18.11.20 um 20:44 Uhr)
    GCM/IT/S/O d-(--) s+:- a? C++(+++) UL+++(++++)$ P L+++>++++ W++ w@$ M--$ PS+(++) PE(-) Y+(++) PGP++(+++) t+ 5(+) R* !tv b+(++++) DI(++) G++ e+>++++ h(--) y?
    Das Ende ist nahe: Dem Harleyschen Kometen folgt der Gammablitz beim Scheißen.

  17. #17
    Mitglied

    (Threadstarter)


    Registriert seit
    Mar 2020
    Beiträge
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Hallo zusammen,

    also ich habe die Tage versucht das umzusetzen was hier geschrieben wurde.
    Da ich an meinem Jitsi-Mett Server nicht verändern wollt, habe ich bei meiner ProxMox Maschine ein Debian mit Apache2 Aufgesetzt.
    Hier habe ich schon eine default index.html und musste nicht umändern.

    Alle Geräte haben eine Statische IP !



    Zitat Zitat von Metal_Warrior Beitrag anzeigen
    Mit deinen anderen zwei Servern verfährst du bitte ebenso. Feste IPs. Egal wie. Nichts ist ärgerlicher, als Umleitungen ins Nichts.

    Anschließend erstellst du auf deinem HTTP-Server eine Config in sites-available, die nichts anderes tut als eine Umleitung von Port 80 auf Port 443 und nennst sie http.conf:

    Code (Apache/.htaccess):

    <VirtualHost *:80>
    RewriteEngine on
    RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [NC,R,L]
    Errorlog ${APACHE_LOG_DIR}/http_error.log
    Customlog ${APACHE_LOG_DIR}/http_access.log combined
    </VirtualHost>
    Ich habe die http.conf mit dem Inhalt erstellt, ich sehe aber die VirtualHost *:80 aber sehe nicht die Umleitung auf 443
    Beziehungsweise verstehe ich die Syntax nicht.


    Code (PHP):
    1. <VirtualHost *:443>      #Dein Apache hört auf alle Anfragen auf Port 443
    2.    ServerName videomeet.mine.nu    # Wenn im HTTP-Header der Server videomeet.mine.nu aufgerufen wurde, hast du hier einen Match
    3.    ProxyPreserveHost On              # videomeet.mine.nu bleibt im HTTP-Header erhalten als Anfrager.
    4.    ProxyPass / http://192.168.0.50:80   # Die Anfrage wird dann intern an die 192.168.0.50 auf Port 80 weitgerleitet.
    5.     ProxyPassReverse / http://192.168.0.50:80 # Und was von der .50 zurückkommt wird wieder nach draußen geschickt.
    6. </VirtualHost>
    @musv Nach deiner Syntac sollte doch alles klappen und logisch sein. Adressen stimmen und die IP Adressen,
    leider kein Erfolg.

    Habt ihr eventuelle Alternative Hilfestellungen ?
    Gruß

    Lock

  18. #18
    Defender of Freedom

    Administrator

    Avatar von Metal_Warrior
    Registriert seit
    Aug 2013
    Ort
    /dev/mapper/home
    Beiträge
    6.244
    ngb:news Artikel
    7

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    @Lock: Die Default-HTML hast du überall auf Debian, und an deinem Jitsi hättest du nix ändern müssen, sondern nur die Seite disablen. Das ist der Grund, warum das Links sind, eben damit man nix verändern muss.

    Und wenn du genau liest, hab ich dir die Umleitung exakt so geschrieben, wie sie funktioniert. HTTPS ist auf 443, weil das der Standardport ist.

    Nochmal, bau bitte EXAKT das nach, was ich dir gesagt hab. Solltest du wieder selber denken versuchen, bin ich raus.
    Für diesen Beitrag bedanken sich Lock, musv
    GCM/IT/S/O d-(--) s+:- a? C++(+++) UL+++(++++)$ P L+++>++++ W++ w@$ M--$ PS+(++) PE(-) Y+(++) PGP++(+++) t+ 5(+) R* !tv b+(++++) DI(++) G++ e+>++++ h(--) y?
    Das Ende ist nahe: Dem Harleyschen Kometen folgt der Gammablitz beim Scheißen.

  19. #19
    Mitglied
    Registriert seit
    Jul 2013
    Ort
    /dev/null
    Beiträge
    2.868

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Zitat Zitat von Lock Beitrag anzeigen
    @musv Nach deiner Syntac sollte doch alles klappen und logisch sein. Adressen stimmen und die IP Adressen,
    leider kein Erfolg.
    Ja, aber auch meinen eigentlichen Vorschlag hast du oben übersprungen. Genau wie Metal_Warrior wollte ich mit der selbst erstellen index.html bei Dir erst mal sicherstellen, dass du:
    1. von außen erst mal auf Deinem Apache landest und der eine Seite ausgibt.
    2. wenn das klappt, der Apache die Umleitung von http auf https hinbekommt und dabei wieder die lokale Seite auf Deinem Apache ausgibt (diesmal über https).
    3. wenn das klappt, der Apache per Proxy auf den Jitsi-Rechner weiterleitet und dort was anfragt (deswegen tcpdump).
    4. wenn das klappt, der Jitsi-Server auf den Apache-Request antwortet.

    Dein Problem dabei ist, dass du von Schritt 1 gleich zu Schritt 4 springst und die Zwischenschritte ignorierst. Dafür brauchst du kein Proxmox, keine zusätzlichen VMs.

    Arbeite bitte die einzelnen Schritte von Metal_Warriors Anleitung ab!
    Für diesen Beitrag bedankt sich Lock

  20. #20
    Mitglied

    (Threadstarter)


    Registriert seit
    Mar 2020
    Beiträge
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Hallo zusammen,

    sorry für die Missverständnisse, ich sehe den Wald vor lauter Bäumen nicht mehr. Ich bin sehr dankbar das ihr so nett seid und mir hier weiterhelfen wollt.

    Ich fange nochmal an, Schritt für Schritt.


    Zitat Zitat von Metal_Warrior Beitrag anzeigen
    Deinem HTTP- und HTTPS-Server, den du ja als Proxy nutzen möchtest, spendierst du bitte eine feste IP. Ob du das mit deinem Router anstellst oder den Server selbst vom DHCP abklemmst und per Static IP konfiguriest, ist egal. Wichtig ist nur, dass er nicht auf blöd mal ne andere IP bekommen kann. Anschließend leitest du genau Port 80 und Port 443 auf diese IP weiter.

    Mit deinen anderen zwei Servern verfährst du bitte ebenso. Feste IPs. Egal wie. Nichts ist ärgerlicher, als Umleitungen ins Nichts.
    Habe ich gemacht, alle Geräte haben eine Statische IP.

    Zitat Zitat von Metal_Warrior Beitrag anzeigen
    Anschließend erstellst du auf deinem HTTP-Server eine Config in sites-available, die nichts anderes tut als eine Umleitung von Port 80 auf Port 443 und nennst sie http.conf:
    Auf dem Proxy habe ich die Datei angelegt:
    nano /etc/apache2/sites-available/http.conf

    Inhalt:
    Code (Apache/.htaccess):
    1.     <VirtualHost *:80>
    2.       RewriteEngine on
    3.       RewriteRule ^/(.*) https://%{HTTP_HOST}/$1 [NC,R,L]
    4.       Errorlog ${APACHE_LOG_DIR}/http_error.log
    5.       Customlog ${APACHE_LOG_DIR}/http_access.log combined
    6.     </VirtualHost>
    7.  
    Ich geben dann
    a2dissite
    ein
    Code (Apache/.htaccess):
    1.  
    2. ur choices are: 000-default
    3. Which site(s) do you want to disable (wildcards ok)?
    bestätige mit Enter.


    Prüfe /etc/apache2/sites-enabled - ob hier alle leer ist:

    Code (Apache/.htaccess):
    1. /etc/apache2/sites-enabled# ls -la
    2. total 8
    3. drwxr-xr-x 2 root root 4096 Nov 23 19:19 .
    Dann kommt:

    Code (Apache/.htaccess):
    1. a2ensite http.conf
    2. Site http already enabled
    3. und
    4. systemctl restart apache2
    Zitat Zitat von Metal_Warrior Beitrag anzeigen
    Rufst du jetzt die Seite (von intern oder extern auf, MUSS ein "Server antwortet nicht" auf HTTPS kommen. Kommt das nicht, hast du woanders was vergurkt.
    Kommt es aber, machen wir weiter:
    Hier muss ich nochmal nachfragen, du meinst als Server den Jitsi.Server, ist das richtig.
    Wenn ich die dyndns Adresse eingeben bekomme ich :

    Code (Apache/.htaccess):
    1. Die Website ist nicht erreichbar
    2.  
    3.  hat die Verbindung abgelehnt.
    4. Versuchen Sie Folgendes:
    5.  
    6. Verbindung prüfen
    7. Proxy und Firewall prüfen
    8. ERR_CONNECTION_REFUSE
    D

    Diese Meldung bekomme ich auch über mein Handy, also über ein extrenen Netz.


    Wenn ich die Lokale IP aufrufe :
    192.168.0.50/
    erhalte ich diese Meldung:

    Code (Apache/.htaccess):
    1. Dies ist keine sichere Verbindung
    2. Hacker könnten versuchen, Ihre Daten von 192.168.0.50 zu stehlen, zum Beispiel Passwörter, Nachrichten oder Kreditkartendaten. Weitere Informationen
    3. NET::ERR_CERT_COMMON_NAME_INVALID
    Wobei das glaube ich nicht interessant ist.
    Was habe ich den bis hier falsch gemacht?

    cat access.log | pastebinit -b slexy.org
    http://slexy.org/view/s2C2O2uNa6

    cat error.log | pastebinit -b slexy.org
    http://slexy.org/view/s2viA52CP8

    cat http_access.log | pastebinit -b slexy.org
    http://slexy.org/view/s20mLEejKl

    Ich habe nochmal die logs hochgeladen.

    Danke nochmals für eure Hilfe.

  21. #21
    Zeitreisender

    Administrator

    Avatar von drfuture
    Registriert seit
    Jul 2013
    Ort
    in der Zukunft
    Beiträge
    7.042
    ngb:news Artikel
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Könntest du bitte noch allen Computern die du da nutzt einen Namen geben, den Zweck des Gerätes und die ip hier in eine Tabelle schreiben und dann jeweils dazu schreiben wo du etwas setzt und zu welchen Geräten die logs gehören. Diesmal geht es theoretisch noch aber später wird das sonst nicht nachvollziehbar
    Für diesen Beitrag bedankt sich Lock
    |_|D *`~{ Ich kenne deine Zukunft }~´* |_|D

  22. #22
    Defender of Freedom

    Administrator

    Avatar von Metal_Warrior
    Registriert seit
    Aug 2013
    Ort
    /dev/mapper/home
    Beiträge
    6.244
    ngb:news Artikel
    7

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    @Lock: Man sieht schon, dass du springst, sonst wäre die Meldung mit "Site http already enabled" nicht gekommen

    Wenn er dir jetzt ein NET::ERR_CERT_COMMON_NAME_INVALID rauswirft, kann es sein, dass du die https.conf schon geschrieben und enabled hast? Sonst sollte da nämlich eigentlich nix kommen.
    Für diesen Beitrag bedankt sich Lock
    GCM/IT/S/O d-(--) s+:- a? C++(+++) UL+++(++++)$ P L+++>++++ W++ w@$ M--$ PS+(++) PE(-) Y+(++) PGP++(+++) t+ 5(+) R* !tv b+(++++) DI(++) G++ e+>++++ h(--) y?
    Das Ende ist nahe: Dem Harleyschen Kometen folgt der Gammablitz beim Scheißen.

  23. #23
    Mitglied

    (Threadstarter)


    Registriert seit
    Mar 2020
    Beiträge
    17

    Re: Fehler: Umleitungsfehler bei Apache Reverse Proxy

    Hallo @drfuture

    ich habe einmal eine Grafik erstellt, hier kann man eventuell erkenn was ich möchte und welche Geräte im Einsatz sind.
    Die dyndns Adressen sind natürlich nicht die richtigen.

    Klicke auf die Grafik für eine größere Ansicht 

Name:	apacheproxyReverse.png 
Hits:	8 
Größe:	178,1 KB 
ID:	58074

    Hier die IPś und die /etc/hosts


    Proxy
    Code (Apache/.htaccess):
    1.  
    2. inet 192.168.0.38/24 brd 192.168.0.255 scope global dynamic noprefixroute eth0
    Code (Apache/.htaccess):
    1. 127.0.0.1       localhost
    2. ::1             localhost ip6-localhost ip6-loopback
    3. ff02::1         ip6-allnodes
    4. ff02::2         ip6-allrouters
    5.  
    6. 127.0.1.1               raspberrypi
    Jitsi-meet
    Code (Apache/.htaccess):
    1. inet 192.168.0.50/24 brd 192.168.0.255 scope global dynamic enp5s0
    2.  
    Code (Apache/.htaccess):
    1. 127.0.0.1       localhost videomeet.mine.nu
    2. 127.0.1.1       jitsiemeet.link jitsiemeet
    3.  
    4. # The following lines are desirable for IPv6 capable hosts
    5. ::1     localhost ip6-localhost ip6-loopback
    6. ff02::1 ip6-allnodes
    7. ff02::2 ip6-allrouters

    Nextcloud Pi

    Code (Apache/.htaccess):
    1.  
    2. inet 192.168.0.70/24 brd 192.168.0.255 scope global dynamic noprefixroute eth0
    Code (Apache/.htaccess):
    1. 127.0.0.1       localhost
    2. ::1             localhost ip6-localhost ip6-loopback
    3. ff02::1         ip6-allnodes
    4. ff02::2         ip6-allrouters
    5.  
    6. 127.0.1.1 nextcloudpi
    Ich hoffe die Informationen helfen dir weiter.

    Gruß Lock
    Für diesen Beitrag bedankt sich drfuture

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •